Solved ChestCommands

Discussion in 'Spigot Plugin Help' started by ConradHD, Jun 10, 2017.

  1. Completely restart your server, and check if the error persists.

    There is no need to use plugman, as chestcommands has its own reloading feature

    /chestcommands reload
  2. Done that many times. I don't use plugman to reload the plugin. It happened after add quests, but i removed that and tried reinstalling the jar file and still nothing. (Only used plugman because it wasn't loading)
  3. That'd make a lot more sense :confused:
  4. It was working before i added the plugin quests. I'll give it a go though.
  5. Yup still isn't working
  6. You sure you installed the right version of quests?
  7. java.lang.ExceptionInInitializerError
    at ~[?:?]
    at ~[?:?]
    at ~[?:?]
    at ~[?:?]
    at ~[PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at com.rylinaux.plugman.util.PluginUtil.load( [PlugMan.jar:?]
    at com.rylinaux.plugman.util.PluginUtil.load( [PlugMan.jar:?]
    at com.rylinaux.plugman.util.PluginUtil.reload( [PlugMan.jar:?]
    at com.rylinaux.plugman.command.ReloadCommand.execute( [PlugMan.jar:?]
    at com.rylinaux.plugman.PlugManCommandHandler.onCommand( [PlugMan.jar:?]
    at org.bukkit.command.PluginCommand.execute( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at org.bukkit.command.SimpleCommandMap.dispatch( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.PlayerConnection.handleCommand( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.PlayerConnection.a( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.PacketPlayInChat.a( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.PacketPlayInChat.a( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$ [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at java.util.concurrent.Executors$ [?:1.8.0_131]
    at [?:1.8.0_131]
    at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.MinecraftServer.B( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.DedicatedServer.B( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at net.minecraft.server.v1_8_R3.MinecraftServer.A( [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at [PaperSpigot-1.8.8.jar:git-PaperSpigot-"8b18730"]
    at [?:1.8.0_131]
    Caused by: java.lang.NullPointerException
    at ~[?:?]
    at<clinit>( ~[?:?]
    ... 28 more
    [05:16:33 INFO]: [ChestCommands] Disabling ChestCommands v3.1.4
  8. Removed it and its still not working.
  9. Rename your plugin folder,
    make a new one, install only chestcommands, does it work then?

    IF it does, try installing quests without changing anything keep the default configs.
    does this work?
  10. Yea that worked. I'm trying to transfer all the files to that new folder and see if that fixes it.
  11. Yeah it didn't work when i moved all the other files
  12. EDIT

    Hmm okay, Move them one by one when you found the broken file, post it here.

    Code (Text):
  13. Ended up being SimpleRename :p Thanks for your help! (Guess they dont like working together)
  14. Good to hear! :D
    • Useful Useful x 1