Chunk Loading TPS Drop

Discussion in 'Performance Tweaking' started by ProjectFTW, May 30, 2017.

  1. Experiencing a 10 second delay of a message coming though in chat after joining the server which is extremely bad. The TPS drops to around 5 under these 10 seconds and returns to 20 after the chat message is being displayed in chat.

    The reason why i know this is caused by the chunks is because each time i do /wild, it will take 10 seconds to even load the blocks up and TPS drops to around 5 under these 10 seconds.
    I have ran several world corruption tests and there is no signs of my world being corrupted nor is my chunks/regions. With this being said, Yes one of the tests was ran by the Official spigot region fixer.

    Specs:
    100 MB/s Bandwidth
    6 GB Ram
    Unlimited SSD Storage
    -------------------------------------------------------
    Local machine & NOT the current machine i am running on!
    CPU isn't the cause as i was running this on my local machine earlier with a Intel Core i7-6950X and 64 GB of RAM only 32 GB was applied to the server.
    -------------------------------------------------------

    Using Spigot as of right now. This is due to PaperSpigot showed no improvement for this issue. (Yes, I have tried changing the Paper.yml and followed several performance guides).

    Plugins (58): FactionsEssentials, RankVouchers, SimpleAutoBroadcast, PlaceholderAPI, DeluxeCommands, PlugMan, DeluxeTags, AutoRestart, ViaVersion, StaffPlus, TopLite, AdvancedReporter, BountifulAPI, ClearLag, ChatControl, WorldBorder, BuycraftX, ProtocolLib, Reflex, MVdWPlaceholderAPI, EnhancedBalTop, FastAsyncWorldEdit, MergedMob, DeluxeMenus, PermissionsEx, EffectLib, Tab, mcMMO, Vault, FastAsyncVoxelSniper, SimpleRename, MoneyPouch, HolographicDisplays, HideAndCustomPlugins, AuctionHouse, VoxelSniper, PlayerVaults, MyCommand, CratesPlus, WorldEdit, Essentials, AnimatedNames, LiteBans, Citizens, TradeMe, WorldGuard, Factions, FactionsTop, FactionUUIDLogout, RandomTeleport, FactionWarsCORE, CombatLogX, EssentialsSpawn, FactionWars, BarGamble, SilkSpawners, DeluxeChat, LinkItem

    All of them are fully working with the latest updates.
    (Removed all DATA from all plugins that had it and reduced the size of each plugin folder which didn't really change anything..)
    No errors and the plugin which takes the highest CPU usage is WorldGuard which currently is 19% of CPU.
    http://prntscr.com/fduwex
    http://prntscr.com/fduwmx

    My question is: What plugins in this list do you believe is causing the issues when loading chunks?
     
  2. What is your view distance at? I have had this issue before and I changed my view distance from the default 10 to around 5-6. Also can you paste the timings report?
     
  3. the easy answer is, post your timings and it should say where its happening
     
    • Like Like x 1
  4. View-Distance: 10 CHANGED to 6.
    I will return with results.

    EDIT: Reduced the delay by around 3 seconds.
     
  5. So then, it isn't really a view distance issue. A timings report will most likely show the cause of the issue you are having :p.
     
  6. I had the same Problem with "EpicWorldGenerator" :(
    I changed the view distance and it worked...

    Enough RAM ?
     
  7. 32 GB RAM tested and still had this issue.
    I have enough ram. Currently running at 6 GB
     
  8. https://prnt.sc/fdv5y5

    It looks like these three guys may be the culprit.
     
  9. So what do you suggest me to do about this?

    EDIT: I haven't used the Signs feature for BuycraftX which i think is strange why it even lists it.
     
    #10 ProjectFTW, May 30, 2017
    Last edited: May 30, 2017
  10. #11 ProjectFTW, May 30, 2017
    Last edited: May 30, 2017
  11. Remove Random Teleport and try.
     
  12. Did not solve the problem at all.
     
  13. upload_2017-5-31_16-2-56.png
    Try a different essentials build.
     
  14. electronicboy

    IRC Staff

    gr8 shotgun approach... there is nothing wrong with essentials when you actually quantify the data, a single task as a user joins really isn't all that bad, they could probably do something to help with the performance of that, but it's not really all that much of an issue unless you're running a server on the scale where plugins like essentials should really be replaced with more suitable solutions. it's not going to be fixed by updating a plugin when they hardly ever touch that area.

    to OP, please actually provide a sample of timings longer than 30 seconds, you should be providing at least 5 minutes of timings at a minimum, v1 timings really doesn't provide a really good view on what is going on.
     
    • Agree Agree x 1
  15. I never stated that there was anything wrong with Essentials. In fact, i really trust their performance and don't really think it is the plugin that causes this issue.
    I will be contacting the host and see if they have better experience in this & hopefully might find me a solution.
     
  16. electronicboy

    IRC Staff

    I said that part to the person above, for you, I partially misread your timings as I'm used to v2 timings from paper, which are actually capable of tracing what plugin actually is causing such lag, and generally tracing it down to where, v1 timings miss a *lot* of data and are generally inaccurate, especially when looking at stuff like this.
    beyond that, the smallish timings samples you've provided don't really allow me to look out for key targets on v1 that usually helps indicate specific issues, if you can run paper for v2 timings, that would be awesome, if you're stuck with spigot, you can try getting a longer sample, maybe 20 minutes or so, however it's just not going to be as accurate or promising.
     
    • Like Like x 1
  17. First of all, Try using essentialsx. Then try to trim your world if you have world border set.