1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Chunks resetting to previous saves?

Discussion in 'Bugs & Feature Requests' started by Puremin0rez, Jun 3, 2013.

  1. Puremin0rez

    Moderator

    Edit: Turns out this might actually be a Craftbukkit/Spigot bug since so many of you are commenting on the issue. I'm moving this over to the bugs section so md_5 can get a better look.

    Hey all,

    I figure at least one of you have experienced this at some-point so I wanted to get some information about it from everyone.

    Over the past 2 days, my server has been reverting random, usually only a few, chunks around the server. They appear to revert to the version that was there the last time the server was restarted (which automatically happens every 12 hours -> my script simply issues "stop").

    I have a script setup to issue "save-all" in console every 30 minutes since the beginning of my server and I can verify that it's definitely doing what it's supposed too (that being that the script is sending the command properly, not that save-all is actually working properly).

    The only thing I did before this problem started appearing was install Multiverse-Core.

    The server has not crashed in months, so it's not loosing data from crashes.

    Is it possible that "stop" is not saving all of the chunks so anything that happens near the time of a automatic restart gets wiped? If that's the case, I could just issue a save-all right before the stop or something.

    Does anyone have some suggestions for me? Should I be using the vanilla auto save method in bukkit.yml (disabled by default) instead of a script doing it manually? I was under the impression save-all was better.

    Thanks for anyone with information about the problem =)

    ( I didn't put this in the bug section of the forums because I don't think it's a Spigot bug )
     
    #1 Puremin0rez, Jun 3, 2013
    Last edited: Jun 5, 2013
  2. jtaylor69

    jtaylor69 Retired Moderator
    Retired

    I had a player complain this morning with the exact quote "Time has reversed" after the server restarted.
    This is the first time such event has happened after a year of hosting.
    I'm using build #888.

    Edit: I am also using save-all, ever since the start.
     
  3. PhanaticD

    Patron

    had multiple people complain about the same issue on my survival server
     
  4. jtaylor69

    jtaylor69 Retired Moderator
    Retired

    I've also had a problem where the chunk at 0,0,0 is now a hole in the world.
    The only way I had found this out is because I wanted to see if I had the arrows bug that others are experiencing.
    Can be seen by multiple players so definitely a server side issue.
     
  5. Puremin0rez

    Moderator

    Huh. So maybe it is an issue...
     
  6. Have that same problem. Instead of it changing a few chunks twice it's rollbacked the whole server.
     
  7. I also have some parts of world not save, but it needs to be a recent change for it to be erased
     
  8. Puremin0rez

    Moderator

    Yeah, it must be a recent change. This didn't start happening until I updated to the latest build yesterday or so.

    Not sure if it's a Spigot or Bukkit thing, don't really see much changed...
     
  9. md_5

    Administrator Developer

    866 - anti xray changed, disable it, try this build, do you have the issue?
    849 - mike's tick stuff
    840 - 832 bukkit update to 1.5.2

    If it broke its either anti xray, mikes stuff or 1.5.2 and bukkit.
     
  10. Might be the anti-xray stuff, I haven't got that enabled and I haven't had any odd issues across 3 servers for the last two weeks, I'm currently running build 882 (yeah I know, I like living on the edge :p) so...
     
  11. Just switched from #897 to #902 this morning with a shutdown, spigot.jar update + start up again. My users too complained about a 5 minute rollback then, so I remembered having read this thread some hour before.

    We already had oreobfuscator deactivated, so that does not seem to help here and I'm a bit worried that the issue is still there, since the commits after #897 should not really be related to that to fix it for the next restart.
     
  12. oO Why use any plugin? You could just have set the autosave interval in bukkit.yml ?!

    The problem isn't the autosave interval, its the fact that it says "saving world" on shutdowns too, but it didn't really finish it, so you've got a rollback to the latest interval save, which in our case was around 5 min ago.
     
  13. Sounds like it is saving the world but the main thread shuts down before the save thread's done saving. The way I stop my servers is that they do a save-all, announce a 5 second shutdown notice, then /stop - and I've not heard anyone mention anything rolling back.
     
  14. jtaylor69

    jtaylor69 Retired Moderator
    Retired

    Explains why my 25Gb core protect database had corrupted on restart.
    Ouch.
     
  15. I tried that and it would never work. Now after a month the autosave plugin isnt even working for us. I tried doing a save-all before shutting the server down and It would still rollback about 10 minutes. Any ideas?
     
  16. PhanaticD

    Patron

    yea im still getting this issue but only on my survival server (only one with orebfuscator on)
     
  17. Puremin0rez

    Moderator

    Still getting the issue aswell.