Citizens plugin not working 1.8

Discussion in 'Spigot Plugin Help' started by ArmyNetwork, Jul 10, 2015.

  1. The citizens plugins for my server is not working. I enter the command: /npc create bob and nothing happens at all. No error message pops up in the chat, or anything. I have the latest version or the plugin, and everything seems to be compatible; however, all commands don't appear to respond in any way. The plugin is indeed listed in green.
     
  2. Try this version: http://ci.citizensnpcs.co/job/Citizens2/
     
  3. I just tried your suggestion and there still is no difference. Nothing in chat pops up, not even "Unknown Command" I've looked on the console for any errors, and I can't find any.
     
  4. What version are you running of spigot?
     
  5. Stacktrace in the console?
     
  6. We're running Spigot 1.8 We've tried another version, in addition to the one you sent, and there still is the same issue; no response after entering the command
     
  7. What do you mean?
     
  8. https://en.wikipedia.org/wiki/Stack_trace
    Typically just a big wall of text that serves as an error log telling you what's wrong with one plugin. I can give a snippet of a stacktrace in my console.

    at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:23) [Spigot.jar:git-Spigot-b8f6402-a646500]
    at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:181) [Spigot.jar:git-Spigot-b8f6402-a646500]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.dispatchCommand(CraftServer.java:642) [Spigot.jar:git-Spigot-b8f6402-a646500]
    at org.bukkit.craftbukkit.v1_8_R1.CraftServer.dispatchServerCommand(CraftServer.java:628) [Spigot.jar:git-Spigot-b8f6402-a646500]
    at net.minecraft.server.v1_8_R1.DedicatedServer.aM(DedicatedServer.java:353) [Spigot.jar:git-Spigot-b8f6402-a646500]
    at net.minecraft.server.v1_8_R1.DedicatedServer.z(DedicatedServer.java:317) [Spigot.jar:git-Spigot-b8f6402-a646500]
    at net.minecraft.server.v1_8_R1.MinecraftServer.y(MinecraftServer.java:623) [Spigot.jar:git-Spigot-b8f6402-a646500]
    at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:526) [Spigot.jar:git-Spigot-b8f6402-a646500]
     
  9. The server runs on a website, so the log restarts every time we close the page or log out