Solved Citizens plugin Playsound not playing sound

Discussion in 'Spigot Plugin Help' started by Vinikis, Jul 9, 2021.

  1. [Solved!! For some reason using ~ ~ ~ as the cords play the sound at the server spawn instead of the player's location, and the hub NPC was near the spawn, I didn't know this not sure if it's normal either lol. I found another way by using the execute command to play where the player is instead, sorry for the trouble :/ ]

    Hi, I'm trying to make the NPCs in one of my servers to make a sound when clicked,
    The hub of my server has an npc that does this and works, but on the other server It doesn't and instead says 'The sound is too far away to be heard' on the console.

    Neither server has an extra citizens addon like CitizensCMD or CommandNPC, and both are using the same command, which is: playsound minecraft:entity.experience_orb.pickup player <p> ~ ~ ~ 1 1

    I copied the hub server and stripped all the plugins and it still works with just Citizens, so I'm not so sure what is going on and what I did to make it work in the first place..

    1.PNG 2.PNG
     
    #1 Vinikis, Jul 9, 2021
    Last edited: Jul 9, 2021
  2. You are not indicating coordinates where to produce the sound (x y z)

    The syntax is as follows
    /playsound <sound> [player] [position;x y z] [volume] [pitch] [minimumVolume]
    Look this
     
  3. I did use ~ ~ ~ though, and it worked perfectly in the first server without using any addition to citizens.
     
  4. Try to remove player and just leave <p>
    playsound ... <p> ~ ~ ~ 1 1
     
  5. It didn't work.

    I could just replace ~ ~ ~ to actual cords where they stand, but in parts like using an npc to warp to a place it wouldn't work.
    it could probably be something about the server's settings that is causing this but I don't remember.