1.15.2 Class path scanning results in depend, softdepend & loadbefore warning

Discussion in 'Spigot Plugin Development' started by MrDienns, Mar 19, 2020.

Thread Status:
Not open for further replies.
  1. So, I'm creating a plugin which dynamically does some class path scanning. Basically, what I'm doing now, is using ClassGraph to find all classes at runtime which extend Event. All works as expected, but I'm given this warning in some cases. For instance, when my plugin found classes from AAC:

    Code (Text):
    Loaded class me.konsolas.aac.api.PlayerViolationCommandEvent from AAC v4.3.8 which is not a depend, softdepend or loadbefore of this plugin.
    I know this error is practically harmless, but I'd still like to hide the warning for potential plugin buyers. Is there any way I can do my class path scanning without getting that error?

    Thanks
     
  2. SteelPhoenix

    Moderator

    • Like Like x 1
Thread Status:
Not open for further replies.