ClearLag: Stop eating my NPCs

Discussion in 'Spigot Plugin Help' started by AaronL98, May 5, 2015.

  1. I've had the same issue for months and I've still not gotten around to actually fixing it. I've tried many times but always unsuccessful.

    I use Citizens NPCs as my main shop system on my server, and I always have to reload citizens, because clearlag keeps deciding to just kill them. I've tried the world filter stuff, but due to it being poorly documented I don't even know if I'm doing it right.
    My config his here: http://hastebin.com/odutefacus.rb
    What I'm trying to accomplish is to stop clearlag killing mobs in the world "Union_Prison"

    Any help is appreciated.
     
    #1 AaronL98, May 5, 2015
    Last edited: May 5, 2015
  2. Your not the only 1 with this problem after doing a few searches on google, i think it started at 1.8 correct me if im wrong. Your hastebin link dosnt work and also, what version of citizens are u using, latest dev? Recommended etc.
     
  3. Are you using a specific mob type for your NPCs? You should be able to disable clearing of that specific mob if the world filter doesn't work.

    Also, your config just goes to hastebin.com - no actual paste.
     
  4. Oh derp, never noticed that lool.
    Fixed it.

    I use a few different mobs, such as zombies, skeletons, iron golems and villagers.
     
  5. Hmm.
    I've always had issues with clearlag's filters as well. I haven't been in a situation where I really needed them, so I've always just used the default ones.
     
    • Informative Informative x 1
    • Useful Useful x 1
  6. Oh, and Citizens version:
    2.0.14-SNAPSHOT (build 1206)
     
  7. x_L

    x_L

    Your best bet is to remove clear lag and use something else
     
  8. Such as? ;/
     
  9. You can always try lowering the entity limits in bukkit.yml.
     
  10. x_L

    x_L

    I
    Idk you have to look around
     
  11. I loaded up citizens and clear lag onto 1 of my empty test servers and ran them both, i cannot seem to replicate this situation BUT, what i did do different to yours is your using you said build #1206 im using 1228# April the 12th, along with the latest clear lag and i cannot replicate your problem i tried to:

    1. Stop restart the server.
    2. Move out of loaded chunks, load them unload them.
    3. Spammed /lagg clear.
    4. And simply remained idle and the npc's don't get delete.

    I also noticed this in build #1212: Fix Citizens messing with unrelated entities, fixes

    2 options i recommend:
    1. Try to use the /citizens save command, it might store your npc's properly (Might help)
    2. Update to the latest April 12th dev build.

    If none of these work my only other thought would be a plugin or your spigot version (Maybe)
     
  12. Hmm.
    I've tried updating citizens but it completely broke the purpose of the NPCs, as CommandNPC is not compatible with it.
     
  13. Aah wait so, you use command NPC to open a shop GUI? Chest Commands? Considering the dev hasn't updated my only recommendations are:

    1. If you do have a dev ask something to create something similar which runs commands on an NPC click.
    2. Try to change your plugin: http://bukkit.org/threads/npc-command-citizens.192595/ fairly new, might work.
    3. Remove clear lag, but it is obviously a big deal on your server.
     
    • Informative Informative x 1
  14. Hmm, looking at that plugin, It's a plugin request and was made over 1 year ago.

    Is it possible that the world filter feature is a whitelist instead of a blacklist of what worlds to filter?
     
  15. Bump.
    I've updated citizens to the latest version, and I also noticed that ClearLag config was missing a filter on the limit-removal feature. Adding my world to this filter, this problem still... persists....
     
  16. You can use the denizen addon to set your npc's to open chestcommands GUI's with scripts, here's an example script that you can use as a template:

    casino:
    Type: Assignment
    Interact scripts:
    - 1 casinoScript
    casinoScript:
    Type: Interact
    Requirements:
    Mode: all
    Steps:
    1:
    Click trigger:
    Script:
    - execute as_player "bar casino"
    - FINISH

    Scripts go in the scripts folder in denizen (obviously :p), just name the file the same name as the name of the script, in this example the file would be casino.yml

    You could also change "as_player" to "as_op", this is how I make it so they can only use the npc to run the command instead of giving them the permission to run it.

    Also, when you use this for your own use, replace the "casino" in bold with whatever name you use for the file name to keep things working properly.

    To assign the npc with the command script, do:

    1. /npc select (select the npc you want to add the script to)
    2. /npc assignment --set casino (in the example I showed you, you would use casino)