Spigot ClickTpa 1.5.1

Clicking chat to accept a teleport request!

  1. Permissions: clicktpa.tpahere does not work in 1.15.2. “DENY” does not work when using / tpahere(Only OP is available).

    [​IMG]

    [​IMG]
     
  2. I have the same exact problem as shuiqing2046 and I'm on spigot 1.8.8. I do have a suggestion. Could you please add two Player-sent-request messages? One would be for /tpa and the other for /tpahere.
     
  3. When using the command / tpahere.
    The other party cannot use "DENY"


    [​IMG]
     
  4. When using the command / tpahere.
    When the other party uses "ACCEPT", the two lines of information are similar and seem unnecessary.

    [​IMG]
     
  5. i believe i found the error. I will update it right now, and please let me know if it has solved your issue.
    I could

    I'll see what I can change.

    EDIT:
    Please do be aware this plugin is for 1.12.2. I haven't tested other versions, so if any problems, let me know.
     
  6. Can you also make the tpa message fully customizable? Something like this:
    Code (Text):
    - "%player% has requested to teleport to you"
    - "some other stuff"
    - "some more stuff"
    - "%accept%  |  %deny%"
     
     
  7. I was thinking about doing this in the new few updates. I'll keep everyone updated!
     
    • Like Like x 1
  8. It works on 1.15.2.
    Thank you for your work,issue solved
     
    • Like Like x 1
  9. humonga updated ClickTpa with a new update entry:

    ClickTpa v1.5

    Read the rest of this update entry...
     
  10. I don't know if you already fixed this but last time I tested your plugin the /tpahere worked like the /tpa command. I was teleporting to the player, not teleporting them to me.
     
  11. This was fixed in a previous update
     
  12. Player-sent-request:
    - '&eYou have sent a request to &6%target%'
    - '&eClick %cancel% to cancel'

    can you add a feature like this?
     
  13. I’ll see what I can do
     
  14. /tpahere is still not working for me, but now the problem is different:
    after the target player has clicked "accept", he gets an error message "The request was canceled because xxx moved!", with xxx being the player who sent the request (and hasn't moved a bit since).

    I also noticed a new related flag in the config.json: Allow-player-to-move: false, and tried to change that to true to see if it might help, it did not. And also noticed that even with that flag set to true, movement still seems to prevent teleportation to target. Does not work as intended?

    And a third note, we used to have the whole message including accept/deny "buttons" concisely on the same line:
    Xxx has requested to teleport to you [accept] [deny]
    That was before, the new way of customizing the message no longer seems to enable that, now the message texts come first and the actual buttons on the next line. Would it be possible to have the placeholders %click-accept%, %click-deny% (or maybe change the existing %accept%, %deny%), to be put anywhere in your customized message, and these would be displayed as actual clickable buttons in that place?
     
    • Agree Agree x 1
  15. I second this
     
  16. Okay /tpahere should finally be fixed. I haven’t released an update yet because i am trying to figure out the placeholders. I should be able to roll out the update soon enough. I also should have fixed the other bugs, but the update for it will happen later.
     
    • Like Like x 2
  17. Hey Guys!

    Due to many requests, I am trying to implement a method to place %accept% and %deny% placeholders in different parts of the Tpa-messages. As of now, it is a challenge to figure out a way to do this, so updates will take longer than usual. I apologize for any inconveniences and I will try to update you guys in the future.

    Thanks!
     
  18. Can you please roll out the /tpahere fix without the new placeholders for now? I need it to work.