[CLOSED] Proxy is offline? Help!

Discussion in 'BungeeCord Help' started by TheWitherinRiser, Jun 26, 2015.

  1. Hey, so I have successfully set up Bungeecord in the past, although this time I seem to have a problem. When ever I restart, or stop and start my proxy server, it never reaches online mode. Here is a files that might help:



    groups:
    TheWitherinRiser:
    - admin
    disabled_commands:
    - find
    player_limit: -1
    stats: 3fca5919-7df7-426c-b8e3-9ff20c290c60
    permissions:
    default:
    - bungeecord.command.server
    - bungeecord.command.list
    admin:
    - bungeecord.command.alert
    - bungeecord.command.end
    - bungeecord.command.ip
    - bungeecord.command.reload
    listeners:
    - max_players: 50
    fallback_server: Hub
    host: 173.236.98.3:26109
    bind_local_address: true
    ping_passthrough: false
    tab_list: GLOBAL_PING
    default_server: Hub
    forced_hosts:
    pvp.md-5.net: pvp
    tab_size: 60
    force_default_server: true
    motd: '&1Another Bungee server'
    query_enabled: false
    query_port: 25577
    timeout: 30000
    connection_throttle: 4000
    servers:
    Hub:
    address: 184.154.92.20:25565
    restricted: false
    motd: '&1Just another BungeeCord - Forced Host'
    ip_forward: false
    online_mode: true
    Crusades:
    address: 173.236.23.230:25565
    restricted: false
    motd: '&1Just another BungeeCord - Forced Host'
    ip_forward: false
    online_mode: true

    26.06 06:20:38 [Server] SEVERE at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)
    26.06 06:20:38 [Server] SEVERE at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:54)
    26.06 06:20:38 [Server] SEVERE at net.md_5.bungee.BungeeCord.start(BungeeCord.java:248)
    26.06 06:20:38 [Server] SEVERE at net.md_5.bungee.conf.Configuration.load(Configuration.java:59)
    26.06 06:20:38 [Server] SEVERE at net.md_5.bungee.conf.YamlConfig.load(YamlConfig.java:61)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.Yaml.load(Yaml.java:412)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:481)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:226)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158)
    26.06 06:20:38 [Server] SEVERE at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:570)
    26.06 06:20:38 [Server] INFO ^
    26.06 06:20:38 [Server] INFO - admin
    26.06 06:20:38 [Server] INFO in 'reader', line 3, column 2:
    26.06 06:20:38 [Server] INFO expected <block end>, but found BlockSequenceStart
    26.06 06:20:38 [Server] INFO ^
    26.06 06:20:38 [Server] INFO groups:
    26.06 06:20:38 [Server] INFO in 'reader', line 1, column 1:
    26.06 06:20:38 [Server] SEVERE while parsing a block mapping
    26.06 06:20:38 [Server] SEVERE Exception in thread "main"
    26.06 06:20:38 [Server] INFO Loaded plugin cmd_list version git:cmd_list:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    26.06 06:20:38 [Server] INFO Loaded plugin cmd_server version git:cmd_server:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    26.06 06:20:38 [Server] INFO Loaded plugin cmd_send version git:cmd_send:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    26.06 06:20:38 [Server] INFO Loaded plugin reconnect_yaml version git:reconnect_yaml:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    26.06 06:20:38 [Server] INFO Loaded plugin cmd_find version git:cmd_find:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    26.06 06:20:38 [Server] INFO Loaded plugin cmd_alert version git:cmd_alert:1.8-SNAPSHOT:"cc3a8c0":1071 by SpigotMC
    26.06 06:20:38 [Server] INFO Discovered module: ModuleSpec(name=reconnect_yaml, file=modules/reconnect_yaml.jar, provider=JenkinsModuleSource())
    26.06 06:20:38 [Server] INFO Discovered module: ModuleSpec(name=cmd_server, file=modules/cmd_server.jar, provider=JenkinsModuleSource())
    26.06 06:20:38 [Server] INFO Discovered module: ModuleSpec(name=cmd_send, file=modules/cmd_send.jar, provider=JenkinsModuleSource())
    26.06 06:20:38 [Server] INFO Discovered module: ModuleSpec(name=cmd_list, file=modules/cmd_list.jar, provider=JenkinsModuleSource())
    26.06 06:20:38 [Server] INFO Discovered module: ModuleSpec(name=cmd_find, file=modules/cmd_find.jar, provider=JenkinsModuleSource())
    26.06 06:20:38 [Server] INFO Discovered module: ModuleSpec(name=cmd_alert, file=modules/cmd_alert.jar, provider=JenkinsModuleSource())
    26.06 06:20:38 [Server] INFO Enabled BungeeCord version git:BungeeCord-Bootstrap:1.8-SNAPSHOT:"cc3a8c0":1071
    26.06 06:20:38 [Server] INFO Using native code compressor
    26.06 06:20:38 [Server] INFO Using standard Java JCE cipher. To enable the OpenSSL based native cipher, please make sure you are using 64 bit Ubuntu or Debian with libssl installed.
    26.06 06:20:38 [Server] INFO Could not load native library: /tmp/bungeecord-native-cipher3632094037757194224.so: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
    26.06 06:20:37 [Server] INFO Could not load native library: /tmp/bungeecord-native-cipher453582238765561263.so: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory
    26.06 06:20:37 [Multicraft] Loaded config for "Mod: BungeeCord"
    26.06 06:20:37 [Multicraft] Starting server!
    26.06 06:20:37 [Multicraft] Loading server properties
    26.06 06:20:37 [Multicraft] Received start command


    online-mode is set to false for all servers in server.properties

    I use the latest bungeecord.jar

    My connected servers are 1.8.7 spigot snapshots.
     
    #1 TheWitherinRiser, Jun 26, 2015
    Last edited: Jun 26, 2015
  2. It says that it enabled BungeeCord-Bootstrap:1.8-SNAPSHOT:"cc3a8c0":1071
    Im not too sure if its the latest version but it does say 1.8-SNAPSHOT. Make sure that the update worked correctly.
     
  3. The server versions are just fine, no worries. Although I did find the source of the problem. Whenever I add my "crusades" server to the config.yml, my proxy server won't start up. Could you check in on that problem?
     
  4. you need to look at your config. It is broken. The permissions at the top. Pass the file through a parser.
     
  5. Then it's most likely a YAML parsing error. Please Pastebin your config.yml and I'll be able to fix it for you.
     
  6. TIP: Clicking reply on the post will show the actual post with the spacing the poster used.
     
  7. I'm aware of that but using Pastebin or something similar would help everyone in the future and the total look and quality of Spigot Forums itself.
     
  8. Wow thanks haha silly mistake I made. Apparently I added:
    1. ip_forward: true
    2. online_mode: true
    Right below all my servers, and it only should have been at the very end. Thanks for the help
     
    • Like Like x 1