Solved Command Aliases

Discussion in 'Spigot Plugin Development' started by Markyroson, May 31, 2017.

  1. Hi there! I have been attempting to add a command alias to my plugin, however, it has not been cooperating. I have added it according to documentation and YouTube videos that I can find, however, it simply (when typed in game) produces "Unknown command. Type "/help" for help.". Any help would be greatly appreciated.

    Please note that this code below is obviously not my complete plugin.yml, merely the relevant part.

    Code (Text):
      st:
            description: Displays basic plugin information
            aliases: ServerTP
    Thank you for your help!
     
  2. ScarabCoder

    ScarabCoder Retired Resource Staff
    Retired

    Wrap it like so:
    Code (Text):
    aliases: [servertp, stp]
     
    • Winner Winner x 1
  3. Thanks! That fixed it for me. Was the issue the fact that it had capitals @ScarabCoder ?
     
  4. No, but that there weren't any [ ] in it.
     
  5. I tried it with and without before posting as the docs say that they are not required for one command and it did not work, that is why I am guessing casing as that is the only real major difference (the poster above just added another alias as an example).