1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Rejected Command line arguments for online-mode not working

Discussion in 'Bugs & Feature Requests' started by PierreLouis, Jun 16, 2013.

  1. Using '-o false', '--online-mode false' doesn't work. It does with plain Craftbukkit, latest dev build.
    Should be an easy fix! ;)
     
  2. Puremin0rez

    Moderator

    It was intentionally disabled as far as I know.

    People were complaining that the online mode setting in server.properties wasn't working but it always ended up being there control panel / GSP was putting the online mode arguments in the startup script, preventing them from changing the mode.

    If you legitimately want this feature back, maybe md_5 will consider it. I personally don't see a point, but we all have our own reasons.
     
    • Like Like x 1
  3. not sure what this issue is here. your not giving us much to work with. Stack traces as well as posting a pastebin of your bukkit.yml, server.properties, and any other 'plugin' or software which modified login.

    in order for the proxy (bungeecord) to function properly, all you have to do is to set "online-mode:false" in your server.properties and have your server IP set to '127.0.0.1' AND have your bungeecord configured to match the port of each server. (your cant use the default port for your server '25565' because thats what the proxy listens on! Set each server to a different port, IE: 25564, 63, etc to allow them to be connected to the proxy and be joinable.

    The proxy handles all of the login stuff, So as long as you have read all of the setup documentation, you should be fine. <-- check that stuff out to answer any more questions!
     
  4. Z750

    IRC Staff


    This. The online/offline mode flags were specifically removed. Set it in your server.properties. I doubt you'll see them come back any time soon.
     
    • Optimistic Optimistic x 1
  5. I didn't know it was intentionally disabled, I guess that makes sense. It's not bothering me, I was just reporting that.
    Anyways, it should be removed from the help then.

    The issue is simple, the '-o' command line switch ( 'java -jar Spigot.jar -o false') doesn't work.
    I don't know how you didn't get that, it's really simple.
     
  6. md_5

    Administrator Developer

    Its not supposed to work - it causes confusion amongst 99% of users due to bukkit putting it in their wiki as the default startup. Mind explaining why you need it.
     
  7. I was just testing my script by passing arguments to it and seeing if the server used them. So I noticed it wasn't working.

    I don't care if it's disabled, I just didn't know and since the option is still in the '--help' screen I thought it was a bug.
    So just a misunderstanding on my part, but removing it from the help screen will make this clearer for others.
     
  8. Nice bump mate, this is from 2013
     
    • Agree Agree x 2