Spigot CommandNPC 1.9.1

Add Commands to your Citizens 2 NPC! 1.12 Ready (When Citizens comes out)

  1. messageofdeath submitted a new resource:

    CommandNPC - Add Commands to your Citizens 2 NPC!

    Read more about this resource...
     
  2. hey could you add that players can do bungeecord commands like server lobby or send %player% lobby
     
  3. messageofdeath updated CommandNPC with a new update entry:

    CommandNPC v1.8.6!

    Read the rest of this update entry...
     
  4. I will add this in v1.8.7. I just uploaded v.1.8.6 with the new commands to better config the commands. I'll see about adding BungeeCord to the plugin.
     
  5. Is there a way so that it runs a command with the players name. such as ./server factions {name}
     
  6. Within the command, simply type '%name' and it will be replaced with there name.
    BungeeCord support will be added in v1.8.7, with the only available command being /server <serverName>. They will not need to have permission for it as the plugin does not run it as a command.
     
  7. Useful plugin! But a small issue here:
    The plugin still send "Command Executed" although I have set
    Code (Text):
    ExecuteCommandMessage: false
    in config.
     
  8. For the time being, make the 'Execute' lowercase. So replace it with "executeCommandMessage". This will be fixed in v1.8.7
     
    • Like Like x 1
  9. Works with bungee cord?
    And if it works how is the command?
     
  10. I have already added this in the soon-to-be released v1.8.7. To change servers you would use the command '/server <serverName>'
     
  11. when are you put the v1.8.7?
    thanks for respond
     
  12. Currently in the works of uploading to dev.bukkit.org, then we gotta wait until they approve it before I update this resource
     
  13. messageofdeath updated CommandNPC with a new update entry:

    CommandNPC v1.8.7!

    Read the rest of this update entry...
     
  14. Hey! Seems like a cool plugin but...it's not working for me

    I'm trying to get npc to give bending with the PK plugin.

    I select the NPC then do:

    /npc cmdadd -o -c /tla choose Earth %player

    I've tried substituting %player with %player% and %name. I've tried switching around the -o and -c. I've tried abbreviating and unabbreviating the command. Nothing works. Every single time it says "You've succesfully added the command to the NPC" and then when i r-click nothing happens.

    Please help; RSVP.
     
  15. The way the commands are executed, you do not need to add the '/'. The plugin automatically enters that in at the beginning after configuration. son use this command. '/npc cmdadd -o -c tla choose Earth %name'. It uses %name
     
  16. @messageofdeath awesome man!
    Thanks for the update on the plugin.
    Would you take in to consideration adding a configurable message for "You can not do this yet!", please.
    Great..Cheers!
     
  17. I'll see about it! Thanks for the suggestion!
     
    • Like Like x 1
    • Like Like x 1