Compiling Bukkit Plugin Error

Discussion in 'Spigot Plugin Help' started by Terrick, May 23, 2015.

  1. So I'm basically trying to re-edit a plugin a friend sent me, and there's a ChatColor error.
    This has happened every time I've tried to compile a plugin I paste into Eclipse, and I can't seem to find the fix.
    I've imported 1.8 spigot as a build, but it hasn't fixed the error.
    These are all over the eclipse project.
    [​IMG]

    The red lines are text I removed for personal reasons, just the underlined errors I'm questioning about.
     
  2. Code (Text):
    ChatColor.LIGHT_PURPLE + "" + ChatColor.BOLD + ""
     
    #2 SlowFxx, May 23, 2015
    Last edited: May 23, 2015
  3. I want the text to be both bold and a color.
     
  4. That's why I mostly use IntelliJ for most of my projects nowadays.
     
  5. Yes, in your case it would be:
    Code (Text):
    ChatColor.LIGHT_PURPLE + "" //set to an empty string
    + ChatColor.BOLD + "String" //your message
     
    #5 SlowFxx, May 23, 2015
    Last edited: May 23, 2015
  6. Just use ยง