Compression commands causing dedicated server lag

Discussion in 'Systems Administration' started by gpugeek, May 31, 2015.

  1. Hey guys,
    Recently, I've been having issues with any compression command, whether it be zip, gzip, tar, etc. The issue is that no matter the file size, it makes my minecraft server lag like crazy, even when the compress is forcefully stopped by me. Again, even when the compression process is stopped, the machine is lagging like crazy too, which is very weird.

    OS: CentOS 6.6
    CPU: Xeon E3-1230v3
    Storage: SSD

    If you need any more information, please say so.

    Thank you SpigotMC community!

    Edit: I just did a mysqldump for one of my databases, and I had this issue again.
     
    #1 gpugeek, May 31, 2015
    Last edited: May 31, 2015
  2. Seems like your dedi cant handle doing lots of task. Mysqldump/compressing/more uses a bit as its doing alot at once.
    I would contact your host to see if some of your ram is defaulty, because if it is you cant really use it.
     
  3. There's a ton of things that it could be, run the top (or htop, whatever you have installed) command on your server and try doing one of the actions that lag your server and keep an eye on your server load, take a picture of it when the server starts to lag. The main things I'm interested in are the following

    [​IMG]
     
    • Friendly Friendly x 1
  4. Will do asap!
     
  5. Search 'cpulimit', you can use it to limit the amount of CPU usage a process can use,
     
  6. Turned out it was the IO on my SSD; I can't compress backups, only rsync the folders. I'd like to be able to compress without my server crashing, though still.
     
  7. Get a small VPS and SFTP or SCP all your zipping needs there. Set up an automation and boom, you have a weeks worth of work to accomplish next to nothing. xD
     
  8. Alright, thanks! I can't believe I never thought of that, thanks for the post!
     
  9. That was meant to be a sarcastic reply. Setting that up would not be very effective. I would consider looking into cpulimit like @ForgedPassport said. My approach is feasible but not very practical. Even better, check to see what the documentation for your compression tool might offer already to alleviate the issue. 'gzip --help' or 'man gzip' (? right)