Consol Error

Discussion in 'Spigot Plugin Help' started by Molotof, Sep 9, 2019.

  1. Looks like the error is in class com.gmail.thelimeglass.Utils.ReflectionUtil. It might be one of TheLimeGlass's plugin. Check your plugins and see if there is some that are in his repos. https://github.com/TheLimeGlass?tab=repositories
     
  2. This is all my plugin:
     

    Attached Files:

    • pla.png
      pla.png
      File size:
      73.9 KB
      Views:
      13
  3. Its most likely Skellett, I'm about 99% sure
     
  4. Oh :/ But I really need Skellett for my skript...
     
  5. Well then contact the dev of Skellett.

    You are using a version of 1.8.x that no one uses, I'm assuming 1.8?!? If you are going to use the 1.8.x series, you should be using 1.8.8, there's absolutely no excuse to use anything below 1.8.8
    Any plugin that supports 1.8.x most likely won't support anything below 1.8.8 due to the fact theres 3 NMS revision numbers for 1.8.x and devs aren't going to want to deal with R1 or R2, it just makes no sense, since no one should be running these versions.
     
  6. So I can change my server version to 1.8.8 without plugin problems ?
    (I'm french sorry bad english)
     
  7. theres a good chance there will be no problems, but I can not guarantee that.
     
  8. Ok I will try it thank you !!!
     
  9. Strahan

    Benefactor

    Obviously the smart thing to do is setup a test server. Make a new folder on your PC and copy all the files of the production server there, then you can experiment without having to worry about nuking your production build. If it works and tests good, you roll it to production. If it pukes, you can work on fixing what is griping all without causing downtime.
     
  10. Ok so, It's okay no error BUT
    My Essentials Spawn and Chat are wrong version
    I already downloaded Essentials 1.8 but still wrong version
    Do u have Essentials Chat and Spawn 1.8.8?
    Thank you !!!!
     
  11. Strahan

    Benefactor

    1.8.8 is the Minecraft version, not the Essentials version. On my 1.8.8 test server I use EssentialsX v2.16.0.3 and it works fine for me.
     
  12. Ok so, still not work.
    I tested EssentialsX v2.16.0.3 and last version but :

    [22:53:15] [Server thread/WARN]: [Essentials] Version mismatch! Please update EssentialsChat to the same version.
    [22:53:15] [Server thread/WARN]: [Essentials] Version mismatch! Please update EssentialsSpawn to the same version.
     

    Attached Files:

    • err.png
      err.png
      File size:
      138.3 KB
      Views:
      8
  13. Strahan

    Benefactor

    You know the whole Essentials suite needs to be changed when you change versions right? You can't just change the primary Essentials jar and call it a day.
     
    • Agree Agree x 1
  14. It clearly said in the console of what do u need to do..
     
  15. where does it say in console what they need to do?