Copying and Pasting HUGE builds

Discussion in 'Server & Community Management' started by Mattpreat, Jul 30, 2013.

  1. Lately I have been having a problem getting a huge single player build over to my MineCraft server. I finally managed to just set it as a world and get to it using Multiverse, although I still need to get it to my main world. I assumed I could just copy/paste it with world edit to get it there, but whenever I do it I just get the error saying the server didn't have enough ram to handle it. I planned to paste it with safe edit but if I cannot copy it there really is no point. My first plan was to do it in sections, but even if I do it in say 15 pieces it would still crash the server and not work. Now that you have heard my story, what would you suggest I do? No other forums have really helped me so I am hoping someone here will know.
     
  2. Cant you use McEdit?
     
  3. Tried that, McEdit was my first choice but the schematic was 90mb and I assumed it was to big. I tried it but worldedit would not recognize it as a schematic file so wouldn't use it. I pretty much gave up on it but if I can still get that schematic to work I would go with that.
     
  4. Dont use WorldEdit to import the schematic use McEdit. You can make and import schematics using that. In other words you can import the schematic with McEdit and it will give you an outline of your build so you can place it within the program. Make sure you save.
     
  5. Alright I need some clearing up with this. How do I get McEdit on my server? I thought McEdit what only for single player, and then to get it onto the server WorldEdit was the only option.
     
  6. WTF is a 90mb schematic? It's larger than my SurvivalGames that has 27worlds combined.
     
    • Funny Funny x 3
    • Agree Agree x 1
  7. Well it says its size is 90,000,000 in filezilla and I swear I read somewhere that it was 90mb. Sorry if this is wrong. Anywase its just a huge city I have been working on. It isnt all built by me so I still am not fully sure what is all there but it is huge.
     
    #7 Mattpreat, Jul 30, 2013
    Last edited: Jul 30, 2013
  8. Okay so I went ahead and downloaded my servers world and tried using the schematic from there. Every time I try I get this error, anybody know what it means and what I can do to fix it?

    [​IMG]
     
    • Like Like x 1
  9. I am using safe edit now for pasting and other worldedits. It works flawlessly and does most of the things I need although it does not help for copying things. Thanks for the reply though
     
    #10 Mattpreat, Jul 31, 2013
    Last edited: Jul 31, 2013
  10. PhanaticD

    Patron

    maybe asyncworldedit?
     
  11. Ahhhhhh
    AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA NO
     
  12. PhanaticD

    Patron

    why not? You make very good points but I just cant understand the reasoning when saying "Ahhhhhh
    AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA NO"
     
  13. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    If you actually read the code you would realize it is done in a rather well done fashion.
     
    • Agree Agree x 1
  14. Same as safeedit. If you read in the comments section of that plugin I already asked if it would work and was told it will not. Thanks for the suggestion though, I am still looking for other options as I still cant get mcedit to work.
     
  15. i have a server.props file that has the world size set to 90000000 and the unpassable border is still at 30000000 does anyone know how to fix that?