Solved CoreProtect isn't showing the block data..

Discussion in 'Spigot Plugin Help' started by PiggiesGoSqueal, May 25, 2017.

  1. Just as the title says, I tried checking block data for multiple places and it said "No block data found for this location." but there is data stored for it.. http://prntscr.com/fc18o1

    How can I fix this? Thanks
     
  2. Can you show config?
     
  3. There's nothing dodgy in your config, it sounds to me as though you may have a corrupted .jar file. Worse case scenario, you may even have a corrupt SQLite database.

    All I can suggest personally is to delete the .jar, restart your Server, download a new .jar from the CoreProtect Plugin Page, restart again and hope that it recognizes the Data in the Database. If not, I'm afraid that you may have to delete the CoreProtect Folder and start over. Possibly using MySQL as a more secure and reliable method to store the data.

    So, just to be clear... if you were to go onto your Server, break a block and then /co i it, it wouldn't say anything? Or is it just with older Data?
     
    • Like Like x 1
  4. Not sure about with the old jar but after uploading a new jar to the server, if I go onto my server and break a block then /co i it, it would say that I broke it. So the issue was the old block data. And with the new jar it still doesn't show block data for old blocks. So I guess that means the database file was corrupt. :(

    Well thanks for your help! I deleted the old/corrupt database file