Bukkit CoreProtect 2.17.5

Fast, efficient block logging, rollbacks, and restores

  1. After more testing I found it can not connect when running the server through a pterodactyl daemon, though when launching the jar manually it works fine
     
  2. is there an option where you can run console command to turn off player /co i, since i want to allow player to buy the permission for limited time, but if they are on /co i, the permission expired they just cannot turn it off, yet the check will be forever on.
     
  3. Is the latest version of CoreProtect compatible with 1.13.2, or is it 1.14 only?
     
  4. Why when I turn on the plugin(/co i), I get an error(CoreProtect - No block data found as grass_block) for example. What should I do? Spigot Server 1.14.1.
     
    #1264 RoffDaniel, May 21, 2019
    Last edited: May 21, 2019
  5. 1.14 only. Check the overview page for the links to the 1.13.2 download.
     
    • Like Like x 1
  6. Hello!

    I am running the latest version of CoreProtect linked with MySQL. Almost everytime I shut the server down, there is 40,000 blocks left to log. Mind you, sometimes this is within 2 hours with one player on.

    Is this a bug or is there something I need to change?

    Running Paper 1.14.1-32
     
  7. That happened to me when I used MySQL and I think the cause was that my host's SQL server was slow. Switching to SQLite fixed the problem for me. Intelli might be able to provide more information
     
  8. Intelli

    Supporter

    Feature requests can be submitted here: https://dev.bukkit.org/projects/coreprotect/issues

    Assuming the data is logging properly during shutdown, then it's likely just a slow MySQL server. 40,000 blocks shouldn't take very long to log.
     
  9. Intelli

    Supporter

    Intelli updated CoreProtect with a new update entry:

    CoreProtect v2.17.4 [Spigot 1.14]

    Read the rest of this update entry...
     
  10. o_O i dont think thats a coreprotect command..isnt that a clear lag command?
     
  11. Intelli

    Supporter

    That isn't a CoreProtect command.
     
  12. Getting this error sometimes

    23.05 14:56:34 [Server] INFO ... 20 more
    23.05 14:56:34 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:316) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_211]
    23.05 14:56:34 [Server] INFO at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_211]
    23.05 14:56:34 [Server] INFO at sun.reflect.GeneratedMethodAccessor46.invoke(Unknown Source) ~[?:?]
    23.05 14:56:34 [Server] INFO at net.coreprotect.listener.EntityListener.onEntityDeath(EntityListener.java:623) ~[?:?]
    23.05 14:56:34 [Server] INFO Caused by: java.lang.NoSuchMethodError: org.bukkit.entity.Villager.getVillagerType()Lorg/bukkit/entity/Villager$Type;
    23.05 14:56:34 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_211]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:798) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.MinecraftServer.a(MinecraftServer.java:953) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.DedicatedServer.b(DedicatedServer.java:396) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.MinecraftServer.b(MinecraftServer.java:1054) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.WorldServer.doTick(WorldServer.java:355) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.World.a(World.java:743) [spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.WorldServer.entityJoinedWorld(WorldServer.java:578) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityTippedArrow.tick(EntityTippedArrow.java:87) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityArrow.tick(EntityArrow.java:188) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityArrow.a(EntityArrow.java:277) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityArrow.a(EntityArrow.java:363) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityLiving.damageEntity(EntityLiving.java:1163) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityVillager.die(EntityVillager.java:446) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityLiving.die(EntityLiving.java:1316) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at net.minecraft.server.v1_14_R1.EntityLiving.d(EntityLiving.java:1359) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at org.bukkit.craftbukkit.v1_14_R1.event.CraftEventFactory.callEntityDeathEvent(CraftEventFactory.java:692) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:505) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:520) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:320) ~[spigot-1.14.jar:git-Spigot-4d24e36-5193f76]
    23.05 14:56:34 [Server] INFO org.bukkit.event.EventException: null
    23.05 14:56:34 [Server] Server thread/ERROR Could not pass event EntityDeathEvent to CoreProtect v2.17.4

    Running on 1.14 Spigot
     
  13. Intelli

    Supporter

    Your server is out of date. The latest build of Spigot is required.
     
  14. Tau

    Tau

    Suggestion:

    Code (Text):
    /co lookup <user> action:(chat | command | kill) regex:"<My regex filter>"
    For better filtering for specific chat messages, for the kill filter, it would regex the mobs customname, if none, the mobs name.
    Code (Text):
    /co lookup <user> time:10h20h
    Max and Min time (to find specific entries)
    Code (Text):
    /co lookup action:container item:<specific item> regex:<Regex for custom name/lore>
    ...

    But i think the best possible feature would be just a "next page" and "previous page" button on the
    Code (Text):
    /co l
    as well as being able to click coords and it enters the tp command in chat for you, That would be a huge time saver.
     
  15. Intelli

    Supporter

    I've posted your suggestion in the ticket system for you: https://dev.bukkit.org/projects/coreprotect/issues/933
     
    • Friendly Friendly x 1
  16. Could really use some sort of re-sync for when someone griefs using a plugin that CoreProtect doesn't track. Spent a couple days building a huge pyramid dungeon thing using WorldEdit, someone comes in and griefs it using GiantTrees before it's actually done. All the data of what's supposed to be there is present, but I can't figure out how to actually put it back.

    Edit to be a bit more specific: friends suggested just rollbacking and restoring the entire temple, but its size is enough to kill my server even with the amount of optimization CoreProtect has. Rebuilding by hand isn't an option, as it's functionally just a load of random WorldEdit schematics tossed haphazardly together. Said structure also still requires digging to get around between individual buildings buried in the sandstone, which is why the griefer was able to plant the plugin trees in the first place. Also, I used a bit of TNT and someone else's help for details at one point, so it's not just me who "placed" this pyramid, technically.

    Edit again because I'm dumb: I'm running 1.12.2 still because the kind of server I run (lots of custom monsters and worlds and other stuff using now-abandoned plugins and vanilla features alike) really doesn't work in 1.13 or 1.14.
     
  17. Intelli

    Supporter

    You can use "/co restore u:<username> t:<time> r:<radius>" on the person who built the pyramid to bring the pyramid back.

    If your server is crashing, you may be running out of memory or experiencing some other issue. You should review your server log for errors.
     
  18. That didn't seem to have done anything, though, and I've since rebuilt the whole place from scratch anyways. Also, it's god damn massive, so I'm not entirely surprised it was causing trouble trying to mess with that much terrain.
     
  19. Intelli

    Supporter

    Intelli updated CoreProtect with a new update entry:

    CoreProtect v2.17.5 [Spigot 1.14]

    Read the rest of this update entry...
     
    • Friendly Friendly x 1
  20. Getting the following error:

    [19:58:41] [Server thread/INFO]: [CoreProtect] Enabling CoreProtect v2.16.3
    [19:58:42] [Server thread/INFO]: [CoreProtect] CoreProtect 2.17.0 or higher is required.
    [19:58:42] [Server thread/INFO]: [CoreProtect] CoreProtect was unable to start.
    [19:58:42] [Server thread/INFO]: [CoreProtect] Disabling CoreProtect v2.16.3

    Server is running Paper 1.13.2 build #622. I recently updated a few plugins and it complained about WorldEdit being a too new version, so I rolled it back to 7.0.0-beta-05 which works. Now it just says "unable to start". What could be making it need the 1.14 version?

    Thanks! Your plugin is fantastic by the way, been using it for years.
     

Share This Page