Could not bind to host localhost

Discussion in 'BungeeCord Discussion' started by Maddyn99, Sep 25, 2013.

  1. Hi,

    Been struggling with Bungee for the better part of a 3 hours now and I give up. I keep getting this error whenever I use either my server IP or 127.0.1.1, 0.0.0.0 . I have tried what the few forum posts I could find suggested and still no luck.

    I am using a VPS running unbuntu 13.04 and multicraft as my control panel.


     
  2. joehot200

    Supporter

    Before you start your server, try typing:
    netstat -ntlp | awk '$4~/:*25565$/{gsub(/\/.*/,"",$NF);cmd="kill -9 "$NF;system(cmd)}'
     
    • Agree Agree x 1
    • Disagree Disagree x 1
  3. prplz

    Supporter

    Are you running spigot on port 25565 too?
     

  4. Yes my hub server is running on 25565....is that a problem?
     
    • Agree Agree x 1
  5. prplz

    Supporter

    Yes, bungeecord is a server in itself, it can't "share" a port.

    It's like:

    Players -> BungeeCord(25565) -> Spigot/Craftbukkit(other ports)

    You can choose any port that's not in use by other programs, but players should never be allowed to connect to it, you need to either firewall it or bind it to localhost if they are on the same machine.
     
    • Agree Agree x 1
  6. Ok that worked, I can see it if i use MC. I am still confused on how to connect to my servers, but this is a step in the right direction. Thanks for your help.