Could not connect to default server, please try again later:io.netty.channel.ConnectTimeoutException

Discussion in 'BungeeCord Discussion' started by Lothean, Jun 3, 2013.

  1. joehot200

    Supporter

    You installed bukkit on your bukkit servers? I do not understand. Do you mean BungeeCord?

    if so, try changing localhost to 127.0.0.1?
     
  2. Oh,so i'ts an epic fail,
    Also tried, but this solution don't work
     
  3. joehot200

    Supporter

    Hmm.
    Well, the fact that it just says this:
    Code (Text):

    [LIST=1]
    [*][COLOR=#000000]15:58:58 [INFO] Query running on 0.0.0.0:25564[/COLOR]
    [/LIST]
    [COLOR=#000000][SIZE=12px][FONT=Consolas]
    Really means that the connection is not REACHING the server. So it is either bungee being misconfigured, or there is something blocking that port.
    Are you sure the port is open?[/FONT][/SIZE][/COLOR]
     
  4. Yeah, i'm sure, i've tested the connection on direct connect.
    The config is correct.
     
  5. LiLChris

    LiLChris Retired Moderator
    Retired

    Remove all your plugins, and try again.

    Also change EULOBBY_01 to EULOBBY01.
    Not sure how well Bungee handles characters like that.
     
  6. I've tried, but this one don't work too :(
     
  7. YoFuzzy3

    Supporter

    Server.properties please?
     
  8. ^This, and are your spigot servers in offline mode?
     
  9. Uploaded on Pastebin: http://pastebin.com/7eW4pjLg
    Yes, on offline mode.
     
  10. YoFuzzy3

    Supporter

    In your server.properties change the IP from blank to 127.0.0.1. Then in your BungeeCord config.yml change EULOBBY_01's address to 127.0.0.1:25564 (just being consistent, localhost would probably also work).
     
  11. This solution dosn't work too :/
     
  12. YoFuzzy3

    Supporter

    It's the only solution that makes sense. Beforehand you had your Minecraft server binded to 0.0.0.0 while it was set to localhost in your BungeeCord's config. You should idealy only have your BungeeCord server running on an external interface, forwarding data to your Minecraft servers which are running on the internal network.
     
  13. It works, problem of the hosting company, i've hosted bungeecord on a little VPS and my servers are on my dedicated server, for security i've used OnlyProxyjoin, thanks for your help ! :)
     
  14. YoFuzzy3

    Supporter

    Oh, you didn't say they were on different machines. Anyway, having localhost in your BungeeCord config won't work. :p But by the sounds of it I'm guessing you fixed it?
     
  15. No, the servers without the recent modification are on the same machine, but my alone BungeeCord.jar running on an external vps, and my Minecraft Servers are in my dedicated server.
     
  16. @The_Doctor_123 I did. I just want to see if anyone from here would help me. Do you think you could help me? Check out those links please.