Could somebody PLEASE help me?

Discussion in 'Spigot Plugin Help' started by Phantonex, May 19, 2016.

  1. Hey! So I am very new to all of this Spigot and plugin stuff. I have completed coding a plugin. I have been following the "Creating a blank Spigot plugin" page. Well, when I go to export it it's supposed to say "plugin.yml", as shown in this picture:
    [​IMG]

    I unchecked .classpath and .project, but plugin.yml doesn't appear in this list! It says that it is supposed to go where you created the project. Is that the workspace folder if I am using Eclipse? If so, where in the workspace folder? Does it go in any of the following folders?

    [​IMG]
    All help will be appreciated!
     
  2. Could somebody please help me?
     
  3. plugin.yml should show in the root folder of the project. (eclipse as far as I know)
     
    • Agree Agree x 2
  4. So in what folder should I put it in?
     
  5. Plugin.yml stays in the root of the plugin folder, export it as normal
     
  6. Is this right?

    [​IMG]

    If you tell me this is right then I will export it.
     
  7. In Eclipse:
    Code (Text):

    YourProjectName
    | > src
    |    > packages
    | plugin.yml
     
    The plugin.yml file goes in the project root directory. In this example that would be YourProjectName
     
  8. So how do I get it there?
     
  9. In Eclipse find where your plugin.yml is currently located and drag and drop it onto the main folder of your plugin.
     
  10. Ok I did that, then exported as normal. Then, I ran the server, but it didn't load my plugin. In the image, you can see it doesn't say "Activating plugin.jar" or whatever.

    [​IMG]
     
  11. Scroll through the console and check for any errors. Did you export the plugin.yml with your plugin?
     
  12. There were no errors, and when I exported, I unchecked .project and .classpath, like it said to do, but I kept plugin.yml checked.
     
  13. Can you paste the contents of your latest log file to here hastebin.com and paste the link here?
     
  14. http://hastebin.com/odeqecupuh.vbs

    The link probably won't work because I have no idea how to use hastebin
     
  15. "Cannot find main class `com.meeku.tutorialPlugin.SpigotBlankPlugin'"
    The main class specified in your plugin.yml needs to match the main class of your plugin.
    my.package.name.MainClassName
     
  16. Hastebin your code and plugin.yml would ya?
     
  17. I fixed and it worked! THANK YOU SO MUCH!! You will be remembered...
     
    • Friendly Friendly x 1