CPU Usage Spike (1000%up)

Discussion in 'BungeeCord Help' started by coco0325, Feb 20, 2020.

  1. upload_2020-2-20_21-38-17.png

    Bungeecord has a cpu usage spike randomly on 130+ players, and the kernel usage is crazy.
    Players also have ping spike at that time.


    (Run on docker)
    java -server -XX:+UseContainerSupport -XX:+UnlockExperimentalVMOptions -XX:+UseCGroupMemoryLimitForHeap -XX:MaxPermSize=256m -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -XX:+AlwaysPreTouch -Xms1G -jar BungeeCord.jar
     
  2. Can you list all your plugins on Bungeecord ?
     
    • Agree Agree x 1
  3. AdvancedBan
    AutoReturnServer
    Bot-Sentry-Bungee
    BungeeAnnounce
    BungeeAntiSwear
    BungeeControl
    BungeeMail
    BungeeTabListPlus
    Cancel-Friend-Request
    Clans
    Friend-Request-List
    HelperBot
    LuckPerms-Bungee
    MaSuiteCore
    MaSuiteHomes
    MaSuiteTeleports
    MaSuiteWarps
    PartyAndFriend
    ServerListPlus
     
  4. Do you have any errors in the console ?
     
  5. No, just lagging
     
  6. Do you know how to use YourKit Java Profiler ?
     
  7. No, do you need that to analyse?
     
  8. Since there is no timings system that's the only thing to analyse.
    Just one more thing, can you send your bungeecord config.yml ?
     
  9. Likely either old gen gc from low memory allocation (I'd suggest at least 4GB) or a ping attack. I believe flamecord fixes the latter, can be found here.
     
    • Agree Agree x 1
  10. config.yml https://pastebin.com/qZVHqT5Z
     
  11. I'll try 4GB, is flamecord stable?
     
  12. [​IMG]

    I've got another image, the bungee cpu usage up to 1491% :(
     
  13. I think it may be caused by an exploit, you should try a BungeeCord plugin like ExploitFixer
     
  14. Where is your -Xmx flag?
    It is missing from your first post
    And in Post #12
    The report is indicating around 8GB of -Xmx ? !!

    -Xmx1G should be OK for up to 512 (or even more) player connections, but as you are running additional plugins, maybe you should use -Xmx2G ?

    Edit
    also there is a missing ':' colon before the -Xms1G
     
    #14 Goldentoenail, Feb 24, 2020
    Last edited: Feb 24, 2020
  15. Now I know. The following threads show up with CPU spikes.
    [​IMG]
     
    #15 coco0325, Feb 24, 2020
    Last edited: Feb 24, 2020
  16. Can you please send your LuckPerms configuration file (take care to remove password lines before)
     
  17. FlameCord not working.
     
  18. Did you fix it ?
     
  19. Yes, I found it was caused by MasuiteWarp.
    I've notified author and fix it.