Bukkit CraftDisplay 5.3.0

Crafting Mechanism From Minecraft Story Mode!

  1. you can make the armorstand visible with this command, /data merge entity @e[type=armor_stand,limit=1,distance=..4] {Invisible:0b}, so far has worked for all the ones that get stuck on me.
     
  2. Hi!
    Little bug found in 5.3.0: enable and disable are not using spelling defined in messages (it always display "enable" or "disable", even if config is modified)

    I have a suggestion also: would you add support for colors in messages? :)
     
  3. I currently not use this plugin on a production server, perhaps use mode 2 instead of mode 3 for crafting table will "fix" the issue?
     
  4. No matter which of the last three versions I try, I'm met with errors. I run a 1.12.2 server. So, as is stated in the version discussion, the latest version is not compatible with my server.

    Still, the two previous versions don't work either. Simply, I install them, add all the permissions to my groups as need be, and then attempt to reboot my server.
    When I use the commands /craftdisplay, I'm again and again with the same unhelpful, confusing, and ominous message:

    "You don't have CraftDisplay."
     
  5. 5.2.0 works on 1.12.2 for me
     
  6. I'm glad for you.

    Anyway, though, it *isn't* working for me, and the above is my problem.

    Any reasons as to why it'd do that?
     
  7. You don't have CraftDisplay. it means that you haven't enabled it, check config/permissions.
     
    #107 Govindas, Apr 5, 2019
    Last edited: Apr 5, 2019
  8. How do I need to adjust the config?

    Please display a full example config (since it's not that long, so you can post it here).
    How *Should* it look?
     
  9. UPDATE * * * *

    So, I've got it working with 5.2.0 on 1.12.2

    It's beautiful! <3
    HOWEVER
    I am having an issue with lingering items.
    On furnaces, after a while, the 'floating' cooking items on top of the furnace do not disappear. There'll be 6 different blocks spinning inside each other, if I've cooked numerous items.

    I can use other blocks to push them OFF the furnace, onto the ground, or to bury them. But ideally, they'd disappear after the items are claimed from the furnace. Have I done something wrong, or is this a setting, or something that can be patched?
     
  10. that's very nice that you got it to work! I get the same problem, so I just disabled FurnaceDisplay in config.
     
  11. Yeah, I don't know what was causing the issue prior. I just deleted everything and tried again.
    Also, that's not really a solution.

    "My leg doesn't work so I stopped walking."
    Nah, brahhhh. Your leg doesn't work so lets fucking take you to the doctor. Let's diagnose that leg. That thing needs some professional attention from the leg-people. Some expertise. Some 1-on-1 attention. That leg needs some physical therapy. Some hands on work.

    Let's fix your fucked up leg goddamnit.
    What sort of solution is denial, avoidance, and ignorance?

    FUCK that shit.
    FUCK your broken leg. FUCK you for trying to live your life without fixing it.

    LETS FIX THIS PROBLEM
     
  12. do not swear, I'm very sensitive to swearing and what was here, is way too far. it's not my own written code so I'm not one who's responsible for fixing it.
     
  13. Okay Okay.

    Yeah, I don't know what was causing the issue prior. I just deleted everything and tried again.
    Also, that's not really a solution.

    "My leg doesn't work so I stopped walking."
    Nah, brahhhh. Your leg doesn't work so lets take you to the doctor. Let's diagnose that leg. That thing needs some professional attention from the leg-people. Some expertise. Some 1-on-1 attention. That leg needs some physical therapy. Some hands on work.

    Let's fix your up leg.
    What sort of solution is denial, avoidance, and ignorance?

    Fix that problem.
    Fix your broken leg. Shame on you for trying to live your life without fixing it.

    LETS FIX THIS PROBLEM
     
  14. Any update for 1.14? I'd die for it.
     
    • Agree Agree x 1
  15. please update 1.14
     
  16. Hi! One of my players is experiencing an issue with items not disappearing from on top of crafting tables, which has resulted in the player not being able to use the tables. He then moved the crafting table, but the items remained in place and have blocked him from being able to build in that spot.

    Our server is running Spigot 1.12.2 and CraftDisplay 5.2.0. The issue has persisted past multiple server reboots and a disabling of CraftDisplay crafting table animations for said player. Any ideas on how to fix this issue?
     
    • Informative Informative x 1

Share This Page