Spigot CratesPlus - Free Crates Plugin! [1.8 - 1.16.4] 4.5.3

A free and great crates plugin for Minecraft

  1. No, I don't look same different crates plugin if this does not work get updated soon. But have the same errors in game and console that you have. Also, holographic display not working or updated me either but try plugin Holograms it 1.14 and should work. But look it on the internet should find it I believe it 1.14.2 though but updated few times remembered it called Holograms that it and on the spigot, not the bukkit one.
  2. Still getting this error, please help i cant read this stuff running 1.14.3

    [17:14:07] [Server thread/ERROR]: Could not pass event PlayerInteractEvent to CratesPlus v4.5.2
    org.bukkit.event.EventException: null
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:320) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:520) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:505) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at org.bukkit.craftbukkit.v1_14_R1.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:429) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.PlayerInteractManager.a(PlayerInteractManager.java:435) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.PlayerConnection.a(PlayerConnection.java:1267) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.PacketPlayInUseItem.a(PacketPlayInUseItem.java:27) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.PacketPlayInUseItem.a(PacketPlayInUseItem.java:1) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.PlayerConnectionUtils.lambda$0(PlayerConnectionUtils.java:13) ~[spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.PlayerConnectionUtils$$Lambda$3741.0000000024080130.run(Unknown Source) ~[?:?]
    at net.minecraft.server.v1_14_R1.TickTask.run(SourceFile:18) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.executeTask(SourceFile:135) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandlerReentrant.executeTask(SourceFile:23) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.executeNext(SourceFile:114) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.MinecraftServer.aW(MinecraftServer.java:898) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.MinecraftServer.executeNext(MinecraftServer.java:891) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.IAsyncTaskHandler.executeAll(SourceFile:99) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.MinecraftServer.sleepForTick(MinecraftServer.java:874) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    at net.minecraft.server.v1_14_R1.MinecraftServer.run(MinecraftServer.java:808) [spigotmc-1.14.3-R0.1.jar:git-Spigot-595711b-e8b39d4]
    • Agree Agree x 1
  3. same getting the same error in my console and not working in general as a plugin right now in-game on the server. Still having same errors messages as you too don't how to help and using 1.14.3 also.
    • Agree Agree x 1
  4. I took it off server and server is running fine,, guess its time to look for another crate reward plugin.. too bad, been useingthis one for long time
    allso running 1.14.3
    • Agree Agree x 1
  5. yeah, maybe time I have had part ways 4 other plugins because 1.14 and no updates.
  6. [16:38:05 ERROR]: Error occurred while enabling CratesPlus v4.4.5 (Is it up to date?)
    java.lang.NullPointerException: null
    at org.bukkit.Location.getBlock(Location.java:100) ~[patched_1.12.2.jar:git-Paper-1616]
    at plus.crates.CratesPlus.loadMetaData(CratesPlus.java:443) ~[?:?]
    at plus.crates.CratesPlus.onEnable(CratesPlus.java:212) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[patched_1.12.2.jar:git-Paper-1616]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:316) ~[patched_1.12.2.jar:git-Paper-1616]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) ~[patched_1.12.2.jar:git-Paper-1616]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugin(CraftServer.java:395) ~[patched_1.12.2.jar:git-Paper-1616]
    at org.bukkit.craftbukkit.v1_12_R1.CraftServer.enablePlugins(CraftServer.java:344) ~[patched_1.12.2.jar:git-Paper-1616]
    at net.minecraft.server.v1_12_R1.MinecraftServer.t(MinecraftServer.java:442) ~[patched_1.12.2.jar:git-Paper-1616]
    at net.minecraft.server.v1_12_R1.MinecraftServer.l(MinecraftServer.java:403) ~[patched_1.12.2.jar:git-Paper-1616]
    at net.minecraft.server.v1_12_R1.MinecraftServer.a(MinecraftServer.java:341) ~[patched_1.12.2.jar:git-Paper-1616]
    at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:289) ~[patched_1.12.2.jar:git-Paper-1616]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:616) ~[patched_1.12.2.jar:git-Paper-1616]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_212]
    [16:38:05 INFO]: [CratesPlus] Disabling CratesPlus v4.4.5
  7. ugggg these spamming errors I have narrowed down to the tick every 300 tick this bugger spams soooooooo annoying. It reminds me of a debug issue. I am soooo getting exhausted with this plugin/ A simple response would be appreciated on an estimated time of an attempt to be fixed. If not does anyone suggest another crate plugin/ Thanks
    • Agree Agree x 2
    • Like Like x 1
  8. Yes it def is annoying all the spam. everything is still functional but the console is horrible :)
    I made a post on the github as well still no response on that one either

    #1628 ronc617, Jul 5, 2019
    Last edited: Jul 5, 2019
    • Like Like x 1
  9. Is there an alternative to this plugin?
    I think it's abandoned....
  10. It's not abandoned they updated to 1.13 haven't update 1.14 and have partway 4 other plugins and there not too many Minecraft alternative for the 5 plugins that had part ways for most either cost money or haven't update again to 1.14 that work just like this crate plugin. Getting the same errors I feel you all I wish help or do something.
  11. I can imagine, but it seems to be abandoned... no answer since months...
    • Informative Informative x 1
  12. @ConnorLinfoot do you have any comment about this at all? It's one thing to keep posting on github, but many of us are actually asking you questions and hoping you have at least read the posts here.

    tbh, i don't even care if you answer the questions, but could you at least click a reaction so we know you saw these?
    • Agree Agree x 1
  13. Why isn't holograms working or the names for the Crates not working?
  14. This build is not fully working on 1.14.3.... unuseful at all.
    I hope the author will wake up because I think everyone will look for other plugins to run their servers.
    • Agree Agree x 1
  15. That's probably why it's a development build.
  16. Is there anyway to make the crate show an item as a reward, then run a command to give that reward (eg show a piece of paper, if they win they get money via eco give %name% 100), everytime I try it the plugin just stops working, even the config example doesn't work.
  17. By far the best crate plugin out there :)
  18. just the developer needs update 1.14 and so do other developers for like 4 other plugins like holographic displays which are 1.14.1 but doesn't work specialty does not work on 1.14.3 server for me.
    • Agree Agree x 1
  19. Holographics snapshot works fine on my 1.14.3 server you have to go the builds and get the latest build jar.