Spigot CustomCrafting | Advanced Custom Recipe Plugin [1.14 - 1.16.x | Free]

Create custom Crafting, Furnace, Anvil, Stonecutter and more recipes! Support for MetaData and more

  1. I probably haven't found the option yet, but how can I change the position of recipes that show up in the recipe book?

    I've also randomly got an error:
    Code (Text):
    15.08 15:07:03 [Server] WARN Unexpected exception while parsing console command "cc"
    15.08 15:07:03 [Server] INFO org.bukkit.command.CommandException: Unhandled exception executing command 'cc' in plugin CustomCrafting v1.4.4.4
    15.08 15:07:03 [Server] INFO     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:48) ~[custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:704) ~[custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchServerCommand(CraftServer.java:689) [custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at net.minecraft.server.v1_13_R2.DedicatedServer.handleCommandQueue(DedicatedServer.java:459) [custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:418) [custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:831) [custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:729) [custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     at java.lang.Thread.run(Thread.java:748) [?:1.8.0_201]
    15.08 15:07:03 [Server] INFO Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
    15.08 15:07:03 [Server] INFO     at me.wolfyscript.customcrafting.commands.CommandCC.onCommand(CommandCC.java:147) ~[?:?]
    15.08 15:07:03 [Server] INFO     at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[custom.jar:git-Spigot-1a3504a-84f3da3]
    15.08 15:07:03 [Server] INFO     ... 8 more
    #301 AnimalMaceYT, Aug 15, 2019
    Last edited: Aug 15, 2019
  2. Wow, this plugin looks really good. I have a couple of questions though:
    Is it possible to add brewing stand/cartographer/loom/grindstone recipes?

    Is there an API to access this plugin, for example to cancel crafting/showing a recipe, or to open advancedcrafting GUI with another block?

    Is there anywhere we can contribute to the code with pull requests for new features?

    Thanks for posting the plugin and thanks for making it free!
  3. Yep fixed it. Is going to be in the next update. The update will take some more time, so for the meanwhile all you need to do to bypass this bug is to directly use "cc give" or "cc lockdown" inside the console. These are the only commands that are available in the console.
  4. I first want to say that I love this plugin. It's so simple and effective, but I'm using PermissionEx to give players permissions to recipes at certain ranks and can't figure it out. If anyone could help me that would be great.
    The recipe is called: recipe compressed_cobblestone
    The permission I added is: - customcrafting.craft.<recipe:compressed_cobblestone>
    Thanks again for this plugin, it's awesome
  5. I think you already asked me that in the youtube comments if I remember correctly, right?:unsure: If not, the fix is simple. just remove the <>.
    - customcrafting.craft.recipe:compressed_cobblestone
  6. Thank you!

    Is there a way to configure in what order items appear in /cc knowledge?
    #306 AnimalMaceYT, Aug 21, 2019
    Last edited: Aug 25, 2019
  7. My players aren't able to craft the knowledge book or use the knowledge command even though I've given them permission via permissionsex and restarted the server. i'm on spigot 1.14.4 with the most recent version of the plugin. even giving them the book directly doesn't work, since they report they can't even open it. there are no errors in the console. i'm not sure what's going on.
  8. For the knowledgebook to open you need to give your player two permissions:

    However there is a bug in the current version where the knowledge book can't be open by players if they rejoin.
    It's gonna be fixed in the upcoming update, but this update will be released by the end of next week.
  9. What's the advanced crafting table?
  10. Can you add recipe creation with a certain amount of necessary things in one slot? For example, to make an iron ingot you need to put 9 iron nuggets in the center of the workbench, rather than lay them out in all slots.
  11. you can already do that. just put in 9 iron ingots.
  12. I'm sorry, I wanted this to work in the furnace. Can this be done?
  13. Unfortunately it is not possible in furnace recipes.
  14. I updated both this plugin and wolfyutilities just to be on the safe side and now none of my recipes are working or recognized by the editor. I see this error show up in my console.

    Code (YAML):
    [ERROR] Could not pass event AsyncPlayerChatEvent to CustomCrafting v1.4.5.0

    : null

    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:320) ~[spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:70) ~[spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:529) [spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:508) [spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    at net.minecraft.server.v1_14_R1.PlayerConnection.chat(PlayerConnection.java:1563) [spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    at net.minecraft.server.v1_14_R1.PlayerConnection.a(PlayerConnection.java:1501) [spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    at net.minecraft.server.v1_14_R1.PacketPlayInChat$1.run(PacketPlayInChat.java:41) [spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_212]

    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_212]

    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_212]

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_212]

    at java.lang.Thread.run(Thread.java:813) [?:1.8.0_212]

    Caused by
    : java.lang.NullPointerException

    at me.wolfyscript.customcrafting.gui.main_gui.recipe.RecipeEditor.lambda$null$10(RecipeEditor.java:58) ~[?:?]

    at me.wolfyscript.customcrafting.gui.main_gui.recipe.RecipeEditor$$Lambda$3739.00000000B9D33E70.onChat(Unknown Source) ~[?:?]

    at me.wolfyscript.utilities.api.inventory.InventoryAPI.onPreChat(InventoryAPI.java:273) ~[?:?]

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_212]

    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_212]

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_212]

    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_212]

    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:316) ~[spigot-1.14.4.jar:git-Spigot-065a373-03b145b]

    ... 11 more
    Any idea what I can do to sort this out? Or will i have to roll back to the old files?
    stack results are bugged.
    eg. I put wool in and it makes 4 string. But it puts the 4 stack back to 1
  16. Yep fixed it. Upcoming update will contain a fix.
    • Like Like x 1
  17. It is correct that the latest CC requires the latest version of WU.
    You probably get errors on start up. These errors may explain what is happening.
    This bug is new to me so not sure what caused it. Do you have the latest build of Spigot? can be checked with /version
    Just to make sure. Sometimes it is Spigot itself causing problems.
  18. Cool can’t wait
  19. Using the knowledge book does nothing and makes it disappear from my inventory. Also, the advanced workbench looks like a normal workbench, and does not give the advanced workbench item back when i mine it, just a normal table. I'm not sure what im doing wrong and I cant find documentation. help!