Spigot CustomCrafting | Advanced Custom Recipe Plugin [MySQL] [1.13.2 - 1.14.4] 1.4.5.6

Create custom Crafting, Furnace, Anvil, Stonecutter and more recipes! Support for MetaData and more

  1. WolfyScript updated CustomCrafting | Advanced Custom Recipe Plugin [MySQL] [1.13.2 - 1.14.4] with a new update entry:

    Advanced Workbench and Knowledge Book Fix

    Read the rest of this update entry...
     
  2. Wanted to let you know it works now. Fantastic work!
     
  3. The en_US.json cannot be edited, because it will be resetted.
    All you need to do is create a seperate file.
    Copy the en_US.json, then rename it. Remember to set the new language name in the main-config.
    Now you should be able to edit it.
    Hope this helps.
     
  4. ability to add potion effects to armor & weapons? would be awesome! other than that great plugin! Also when using custom durability, how would I repair an item that has custom durability or is that impossible?
     
    #346 swiggasttv, Sep 30, 2019
    Last edited: Sep 30, 2019
  5. Hi wolfy! It still does not work :(, even doing what you detailed to me, in the configuration file it is automatically put in_US after I modify it :/
     
  6. There's a bug with the recipe item names. When i rename the resulting item of the recipe, the colors glitch. I rename using the cc gui and an item renamer plugin. The result are the same. Ex. I rename an item to &f1 &btest &f1 and it comes out as &b1 &btest 7f1. No matter what i try still same result. Here's a proof: https://imgur.com/6oV0WVQ
    That first dot should've been white. Also the dot's form changed slightly if u notice carefully, due to that color bug. This happens on cc v1.4.5.5 and paper 1.14.4
     
  7. make sure to edit the main-config while the server isn't running. so stop the server before editing it.
     
  8. So you have renamed the item with the ItemCreator, right?
    It should automatically set &r infron of the name. It would be &r&f1 &btest &f1 instead.
    It only adds the &r if the name starts with &f, because for some reason the &f won't reset any previous color codes if used as the first color code (don't ask me why...).
    If it doesn't add it, do it manually and name your item &r&f1 &btest &f1. This shuold fix it.
     
  9. Found a fix for that but thanks for the tip. One thing i noticed also, is that if you put a dyed shield as result in a recipe it gets reset to regular shield after saving the recipe. Ex. shield + black banner= black dyed shield>then it gets reset when the recipe is crafted
     
  10. Hello author

    The player's green book cannot display the recipes we designed.:cry:
     
  11. What do you mean it can't display them? How do you your recipes look like? Or can't the players open the book at all?:unsure:
     
  12. Hello some errors in 1.13.2 spigot

    Code (Text):
    [21:16:50] [Async Chat Thread - #10/ERROR]: Could not pass event AsyncPlayerChatEvent to CustomCrafting v1.4.5.5
    org.bukkit.event.EventException: null
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:316) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:66) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:507) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:489) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at net.minecraft.server.v1_13_R2.PlayerConnection.chat(PlayerConnection.java:1543) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:1481) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at net.minecraft.server.v1_13_R2.PacketPlayInChat$1.run(PacketPlayInChat.java:39) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_171]
        at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_171]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_171]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_171]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_171]
    Caused by: java.lang.NullPointerException
        at me.wolfyscript.customcrafting.gui.main_gui.recipe.RecipeEditor.lambda$null$10(RecipeEditor.java:58) ~[?:?]
        at me.wolfyscript.utilities.api.inventory.InventoryAPI.onPreChat(InventoryAPI.java:273) ~[?:?]
        at sun.reflect.GeneratedMethodAccessor1145.invoke(Unknown Source) ~[?:?]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_171]
        at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_171]
        at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:312) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        ... 11 more

    [21:14:32] [Server thread/WARN]: [CustomCrafting] Task #427456 for CustomCrafting v1.4.5.5 generated an exception
    java.lang.IllegalStateException: Duplicate recipe ignored with ID test:skullhead
        at net.minecraft.server.v1_13_R2.CraftingManager.a(CraftingManager.java:86) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at org.bukkit.craftbukkit.v1_13_R2.inventory.CraftFurnaceRecipe.addToCraftingManager(CraftFurnaceRecipe.java:28) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at org.bukkit.craftbukkit.v1_13_R2.CraftServer.addRecipe(CraftServer.java:1157) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at org.bukkit.Bukkit.addRecipe(Bukkit.java:667) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at me.wolfyscript.customcrafting.handlers.RecipeHandler.registerRecipe(RecipeHandler.java:274) ~[?:?]
        at me.wolfyscript.customcrafting.handlers.RecipeHandler.injectRecipe(RecipeHandler.java:286) ~[?:?]
        at me.wolfyscript.customcrafting.gui.main_gui.recipe.RecipeCreator.lambda$null$7(RecipeCreator.java:295) ~[?:?]
        at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftTask.run(CraftTask.java:81) ~[Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at org.bukkit.craftbukkit.v1_13_R2.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:392) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:889) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:417) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:831) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:729) [Spigot-1.13.2new.jar:git-Spigot-1a3504a-dfa7583]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_171]
     
  13. WolfyScript updated CustomCrafting | Advanced Custom Recipe Plugin [MySQL] [1.13.2 - 1.14.4] with a new update entry:

    Config fixes for 1.13.2 users & MySQL bug fix

    Read the rest of this update entry...
     
    • Winner Winner x 1
  14. This is due to how Minecraft handles NBT tag data. Items in the hand (like your pumpkin) can hold many NBT tags, but blocks on the ground cannot. I'm not sure if it would be possible to "fix" this, but if there is a way it would be very difficult.
     
  15. Was wondering if its possible for you to implement my suggestion

    Suggestion:
    Items saved into a list, if placed, etc, the block when broken will return as the custom block/item?
     
  16. Yep, already working on it. In fact it is nearly done, the only thing where it is currently unstable is when placing doors, bed or any other 2 block structures. But I will get it to work.
     
    • Like Like x 2
  17. Thanks for the mod. Very easy to use and opens lots of possibilities!

    Sorry if this has been asked before - is it possible to do an ore dictionary-like approach within a recipe?

    Say I wanted a recipe that takes 1x ANY log/wood and 1x apple - do I have to make multiples of the recipe that specifically uses each variety of log / wood / stripped wood, or is there some way I could avoid this and just have a single recipe?
     
  18. Hiya!!

    Theres a way to create a recipe on avil with 2 same books to make a more high level of book?

    i try to create a anvil recipe with 2 protection IV to make a result of protection V but i get this message
    "[CC] Cannot Save a empty recipe! Check the Result and the Source/Ingredients"