Spigot CustomJoin + PermissionJoin 1.5

Display Messages, OnJoin Operators, PlaceHolders, Fireworks and More...

  1. georgetheepic123 submitted a new resource:

    CustomJoin - Display Messages, OnJoin Operators, Variables and more...

    Read more about this resource...
     
  2. georgetheepic123 updated CustomJoin with a new update entry:

    Added Many More PlaceHolders!

    Read the rest of this update entry...
     
  3. pls add a changeable prefix. It does not look very nice when a plugin tells all its Name by default.
    Every Owner should decide if he wants a prefix enable and if its enabled, decide how it Looks.
     
  4. CloudeLecaw I don't undertsnad what you mean? I'll add a changeable prefix for CustomJoin ok?
     
  5. 09.08 11:01:47 [Server] WARN Caused by: java.lang.UnsupportedClassVersionError: com/george132222222/CJ/CJ : Unsupported major.minor version 52.0

    52.0 is Java 8

    You just developed the current Version for Java8 =(

    Pls recompile to Java 7 to reach more owners.
    Java 7 is still the defeault for most MC-Servers
     
    #9 CloudeLecaw, Aug 9, 2015
    Last edited: Aug 9, 2015
  6. Cloude, Could you rate if i do?
    Ill work on it now
     
    • Like Like x 1
  7. Plugin is still only for Java 8 =(

    [12:26:17 WARN]: Caused by: java.lang.UnsupportedClassVersionError: com/george132222222/CJ/CJ : Unsupported major.minor version 52.0

    Sure why not? But i will not rate if its not running on the mc java 7 server because 1.) i cant test it 2.) it would not be fair to give a bad rate just because you didnt made it for java 7/8 so i wait for a further version and look if u may support j7/8 with this plugin or just develop it for java 8. both is ok - but the current situation is still that i think u would get more DLs when the most % of pcs users also can use it. I saw you allready reached 25 downloaded and im petty sure ...lets say the half of them was disapointed because nowhere was listed that this plugin currently just supports Java 8 (like i was ^^) and didnt run on their server.
     
    • Agree Agree x 1
  8. http://pastebin.com/e0qnSsxE

    its not the best Idea to use Versions for 1.7 and one for 1.8.
    Idea: A Java7 Compile Also works on Java8. Maybe you can do it to get a J7 Version of the Plugin to run. i asked a dev and he told me normaly there are just a few different processes between Java7 and 8 Plugins.
     
  9. This is the only error. All other commands should work? I just need to get the error and catch it
     
  10. this is the only error i got on loading currently :)