DataPack Custom Dimensions Not Loading

Discussion in 'Server & Community Management' started by ProtoTwo, Jul 4, 2021.

  1. Hey all!

    Small issue Ive been encountering recently... I have a DataPack that creates custom terrain as well as a few extra world for users to play around in, it works fine on my testing server but when its uploaded to the main server it wont create the extra worlds (terrain gen is fine) and the server wont recognize the worlds if they are imported from the testing server. Dose anyone have any ideas why this would be happening?

    I tried copying over a clean version of the DP from my testing server and disabling world management plugins like worldguard but still no luck...

    EDIT: Poking around in level.dat with NBTExplorer shows that the worlds or "dimensions" are showing up with all of their properties but they arent being generated by the server. Hope this somehow helped

    EDIT2: Changed the title to be more clear

    Thanks for stopping by, any assistance is greatly appreciated!
     
    #1 ProtoTwo, Jul 4, 2021
    Last edited: Jul 4, 2021