**deleted by user**

Discussion in 'Spigot Plugin Help' started by Willymcfly, Jul 27, 2018.

  1. **deleted by user**
     
    #1 Willymcfly, Jul 27, 2018
    Last edited: May 8, 2020
  2. You can download the string-ids branch of WorldEdit, it added support for the 1.13 API a week ago. A little warning though: these builds are experimental.
     
    • Like Like x 1
  3. Have you installed latest WorldGuard from string-ids branch too?
     
  4. I'm getting the following error while use /schematic load x(file)
    Code (Text):
    [15:31:14 ERROR]: [WorldEdit] An unexpected error while handling a WorldEdit command
    java.lang.reflect.InvocationTargetException: null
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_172]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_172]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_172]
        at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_172]
        at com.sk89q.worldedit.util.command.parametric.ParametricCallable.call(ParametricCallable.java:228) ~[?:?]
        at com.sk89q.worldedit.util.command.SimpleDispatcher.call(SimpleDispatcher.java:125) ~[?:?]
        at com.sk89q.worldedit.util.command.SimpleDispatcher.call(SimpleDispatcher.java:125) ~[?:?]
        at com.sk89q.worldedit.extension.platform.CommandManager.handleCommand(CommandManager.java:249) ~[?:?]
        at sun.reflect.GeneratedMethodAccessor8.invoke(Unknown Source) ~[?:?]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_172]
        at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_172]
        at com.sk89q.worldedit.util.eventbus.MethodEventHandler.dispatch(MethodEventHandler.java:58) ~[?:?]
        at com.sk89q.worldedit.util.eventbus.EventHandler.handleEvent(EventHandler.java:73) ~[?:?]
        at com.sk89q.worldedit.util.eventbus.EventBus.dispatch(EventBus.java:187) ~[?:?]
        at com.sk89q.worldedit.util.eventbus.EventBus.post(EventBus.java:173) ~[?:?]
        at com.sk89q.worldedit.bukkit.WorldEditPlugin.onCommand(WorldEditPlugin.java:228) ~[?:?]
        at com.sk89q.bukkit.util.DynamicPluginCommand.execute(DynamicPluginCommand.java:54) ~[?:?]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at org.bukkit.craftbukkit.v1_13_R1.CraftServer.dispatchCommand(CraftServer.java:693) ~[spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.PlayerConnection.handleCommand(PlayerConnection.java:1634) ~[spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.PlayerConnection.a(PlayerConnection.java:1469) ~[spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) ~[spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) ~[spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.PlayerConnectionUtils.a(SourceFile:10) ~[spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_172]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_172]
        at net.minecraft.server.v1_13_R1.SystemUtils.a(SourceFile:198) [spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.MinecraftServer.w(MinecraftServer.java:884) [spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.DedicatedServer.w(DedicatedServer.java:411) [spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.MinecraftServer.v(MinecraftServer.java:819) [spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at net.minecraft.server.v1_13_R1.MinecraftServer.run(MinecraftServer.java:717) [spigot-1.13.jar:git-Spigot-f68f5a8-095239d]
        at java.lang.Thread.run(Thread.java:748) [?:1.8.0_172]
    Caused by: java.lang.NullPointerException
        at com.sk89q.worldedit.extent.clipboard.io.legacycompat.SignCompatibilityHandler.isAffectedBlock(SignCompatibilityHandler.java:38) ~[?:?]
        at com.sk89q.worldedit.extent.clipboard.io.SchematicReader.read(SchematicReader.java:203) ~[?:?]
        at com.sk89q.worldedit.command.SchematicCommands.load(SchematicCommands.java:117) ~[?:?]
        ... 32 more
     
  5. I don't believe they completed the update of schematics yet
     
    • Like Like x 1
    • Funny Funny x 1
  6. Yep. They have also removed "getRegionManager(World world)" method from API..
     
  7. Maximvdw

    Benefactor

    Patience young padwan
     
    • Agree Agree x 2
    • Like Like x 1
    • Funny Funny x 1
    • Winner Winner x 1
  8. if you are trying to load a schematic from 1.12 in 1.13, it may not have backwards compatibility. Also, not sure if World Edit is still supporting numerical names for blocks or only their new ids. You can read a post from the plugin dev here
     
    • Agree Agree x 1
  9. Yeah, old schematics may not work anymore. Try
    1. Put the schematic on a <=1.12.2 world
    2. Update that world
    3. Try remaking the schematic in an updated version
     
    • Like Like x 1
    • Agree Agree x 1
  10. Bump

    Has any updated experimental version come out with proper schematic support yet?
     
  11. I doubt it.
    Did you check their build server and clicked on recent changes to see what nightly builds have 'fixed' or 'new' ?
     
  12. I'm getting the same error when I try to //set, //replace, //paste.
    Schematics aren't working even if created on server then reloaded.

    *sigh*
     
  13. We you using the latest version? It works fine for me.

    Where the schematics made in 1.13? If not, then they will not properly load.
     
  14. Yes and yes.
    I'll try and reinstall it later one.
     
  15. It;s not jsut schems as I have said in an earlier post. The same issues as th OP however there's anew build from today so we'll see if that works now
     
  16. If schematics still save with numerical ids instead of the string name, then you need to wait for a fix on World Edit. (As you can tell I haven't played enough with the new schematics in 1.13 yet)

    Also, people using commands that change blocks (//set, //replace, etc) need to use string ids instead of the numerical ids. If you need help with finding the string ids, you can do F3 + H to show tooltips and get the string id of any block by hovering over it in your inventory or the creative inventory.
     
  17. thank you so much, i couldnt find it anywhere