Spigot DeluxeMenus 1.13.3

The all in one GUI menu plugin!

  1. SlimeDog

    Moderator Patron

    For heaven's sake. Every build doesn't get released. Among other reasons, it might have failed a test. Be happy that he checks.
     
  2. Alright alright, chill. Jesus

    Was just wondering coz every other version follows correctly, this is the first missing one that I see.
     
  3. Andre_601

    Supporter

    Why do people even care that a version skips from x.x.1 to x.x.3?
    It's just a version number.
     
    • Agree Agree x 1
    • Winner Winner x 1
  4. SlimeDog

    Moderator Patron

    So you ask a question, but you don't really want an answer. I'm chilled.
     
    • Winner Winner x 1
  5. Clip, when I updated, I run a skyblock with menus instead of commands for most functions, but now most of the menus that open a skyblock gui (for example, in deluxe menus click "Top Islands" and it opens the /island top gui from the skyblock plugin ---- everytime deluxe menus opens one of these menus the newly open gui doesn't function and users can remove items from it -- whereas when i type /island top to open the gui it functions correctly (the call from deluxeMenus seems to be making it not work)? Could you suggest some solutions, it was working before. Here is my dm file that calls the /island top function: https://pastebin.com/LThsH4QN
     
  6. I was able to fix it by adding a delay, thanks clip!

    - waqe

     
  7. ===================
    Good Update
    ===================
     
  8. SlimeDog

    Moderator Patron

    Please think what someone would need to know to help with your issue. Consider:
    • Spigot version (note that "latest" is not a version)
    • DeluxeMenus version (again, "latest" is not a version)
    • Copy of config.yml
    • Copy of menu file
    • Any DeluxeMenus-related errors/warnings in-game and from console/log
     
  9. '13':
    material: head;2k17
    data: 0
    slot: 12
    priority: 1
    amount: 2
    display_name: '&a&lMembers #2'
    lore:
    - '&7Upgrade your max members'
    - '&7size. &bCurrent members: &7%askyblock_team_size%'
    - '&8'
    - '&8 ▪ &7New members: &a4 ☻'
    - '&8 ▪ &7Price to unlock: &a10.000 ⛁'
    - '&8'
    - '&7Status: &a&lUNLOCKED ✔'
    view_requirement: BukkitPlayer.hasPermission("members.4");


    i want to make it so this old config works with the 1.11.1 version of deluxemenus. what do i need to change so it works with the 1.11.1 version
     
  10. need update for 1.14.2 and been told players can remove items form menus...
     
  11. Andre_601

    Supporter

    Latest version runs on 1.14.2 and there should be a fix to prevent dupe-glitches.
     
  12. Hey, so my players are able to take out items of the gui, how do i disable this? if this is a feature, might be a bug i think..
     
  13. players arent seeing their names in the guis all they see is %player_name% did i do something wrong is there a permission based reason they dont see their names even in the example menu when i open it i dont see my skull or name can anyone help me understand what i should do
     
  14. Andre_601

    Supporter

    You need to download the Player expansion through PlaceholderAPI as this isn't done automatically.
    1. Run /papi ecloud download <expansion> where <expansion> would be the name of your expansion.
    2. Reload PlaceholderAPI with /papi reload
     
  15. thank you andre_601 i figured it out literally the moment i recieved a reply from you i was mistaken when i thought the placeholders were already installed silly me it took me a whole 20 minutes to realise i had to reload the papi but i do appreciate your prompt response i do however have another question that i wonder if you or anyone else can help me with as i am still learning but i am getting somewhere i want to hook mcmmo i am trying to learn how to make a rankup system with mcmmo and jobs requirements to rankup and i am totally confused as to how to make the requirement needed for say herbalism or another stat i will eventually get it but i am still learning how to use notepad++ so everything i wwrite in comes up as error and dm wont reload i hope i explained this properly as you can tell my typing skill are bleh lol
     
  16. Andre_601

    Supporter

    I recommend reading the wiki of DeluxeMenus (https://github.com/help-chat/deluxemenus/wiki).
    You should also join the HelpChat Discord as this is the best place to receive fast support for DeluxeMenus: https://helpch.at/discord
     
  17. So i saw that the native versions have changed on the main page. Will there be any issues using the latest version on a 1.8.8 server?
    On the startup i only had one error for a missing event
    Code (Text):
    ERROR Plugin DeluxeMenus v1.11.3 has failed to register events for class com.extendedclip.deluxemenus.PlayerListener because org/bukkit/event/entity/EntityPickupItemEvent does not exist.
    , but that is understandable. Still is the plugin will we fully working on lower legacy versions or it may have server/plugin breaking issues?

    Will i have to use older version like 1.10.5?
     
  18. Put it on a test server and try it.
     
  19. This is what i did. It is not running well, had to use older version 1.10.5
     
  20. I want to make a GUI for the askyblock commands and add custom things to that gui. I want to get some tips on how should I do it and how can I make it works without any problems