Bukkit Denizen 1.0.6

A high-power scripting engine for Spigot!

  1. on player right clicks <ID> :
    ID You cannot use this format.1:5
    Can only be stone
     
  2. Yeah you have to actually give a valid material *name* not number. Numeric IDs have not been supported in minecraft for several years now.
     
  3. Then how do I destroy the crop cube?
     
  4. what
     
  5. I wanted to test wheat at different growth stages and then detect players destroying them, but I couldn't do that right now.
     
  6. I believe in 1.12/below it's "on player breaks crops:" and in 1.13/above it's "on player breaks wheat:" (the material name was changed)
     
  7. mcmonkey updated Denizen with a new update entry:

    Denizen 1.0.3, for Minecraft 1.13 and below

    Read the rest of this update entry...
     
    • Like Like x 2
  8. @mcmonkey Is there a changelog or something? I searched several times but where not able to find one
     
  9. I keep getting a warning in my console on start up from Quests that says, "[Quests] Denizen was detected, but is not enabled! Fix Denizen to allow linkage."
    I did not see anything in the either mods config files that refers to linkage etc.
    The only other thing I can think of is perhaps it is because Quests loads before Denizen.
    I tried the simple hello world script and it worked just fine so it appears Denizen is working though.

    Server: This server is running CraftBukkit version git-Spigot-140f654-b446cb5 (MC: 1.13.2) (Implementing API version 1.13.2-R0.1-SNAPSHOT)
    Denizen: v1.0.3-SNAPSHOT (build 1652-REL)
    Quests: v3.5.1-b${env.BUILD_NUMBER}
     
  10. I was going to ask about the build number on quests there but apparently that's legitimately the version label ("-b${env.BUILD_NUMBER}") on the official copy of latest Quests from @HappyPikachu ... interesting.

    That'd be an issue with Quests, should report there.
    It is very likely indeed that Quests loaded before Denizen... as Quests has a bad plugin.yml (it doesn't list Denizen as a softdepend), it should list that here: https://github.com/FlyingPikachu/Quests/blob/master/src/main/resources/plugin.yml#L9
     
  11. First, apologies for the build version. Typically Jenkins would replace that string, but several Spigot users came forward to ask that I upload a version of Quests directly to Spigot for server hosts that to not allow plugins hosted on external sites. Future versions will go back to Jenkins-only, thus rectifying the issue.

    Second, mcmonkey is correct that Denizen should be listed as a softdepend, so expect that in the next Jenkins build, available within the hour. However, I'd like to note that it'd be equally effective for Denizen to add 'loadbefore: [Quests]' to its own resource (and perhaps it should for anyone using previous builds of Quests).
     
  12. SlimeDog

    Patron

    As a matter of principle, it seems to me that a plugin that depends on another should define the dependency, rather than expecting the "master" plugin to define all of the plugins that depend on it. Just sayin' ...
     
  13. I'd recommend you do the same I do for most Denizen builds here: download the build from jenkins and reupload that to Spigot. Ensures a clean proper copy and uses Spigot-hosted files for those that need it.
    Thanks for fixing that quickly!
     
  14. mcmonkey updated Denizen with a new update entry:

    1.0.3 R2 (Build 1654) - Patch for latest Spigot 1.13.2

    Read the rest of this update entry...
     
  15. SlimeDog

    Patron

    #136 SlimeDog, Dec 23, 2018
    Last edited: Dec 23, 2018
  16. Did a timings paste cause I noticed some lag and thought I'd report this, using latest Denizens Dev build to date = http://ci.citizensnpcs.co/job/Denizen_Developmental/499/
    And Latest Citizens Dev build to date = http://ci.citizensnpcs.co/job/Citizens2/1605/
    upload_2019-1-1_17-59-55.png
    Ref: https://timings.aikar.co/?id=0edef60dfce846a5b589d513a6be6738
    Should I report this to Citizens Github issue tracker aswell if it's of concern?


    EDIT - There was a Major bug with latest paper release so it may be in relation to that, I'll keep an eye on it anyway and continue to check timings, disregard the previous messsage for now, will let u know if the issue occurs again in the latest stable build anyway, will be in touch take care :)
     
    #138 Alter-Ego, Jan 1, 2019
    Last edited: Jan 1, 2019
  17. mcmonkey updated Denizen with a new update entry:

    1.0.3 R3 (Build 1655) - patch for more spigot shenanigans

    Read the rest of this update entry...
     
  18. Hi, i'm using the 1.0.2 version of your plugin and i'd like to use the "on (un)equip" events, but the unequip event seems to work only when i'm in creative mode. When i switch in adventure or survival modes, i only get the "equip" message when i equip my helmet, but when i unequip it nothing happens, even in the console. It's like the code isn't even read. Here's my script :

    oxygen:
    type: world
    events:
    on player equips helmet:
    - narrate "Helmet equipped !"
    on player unequips helmet:
    - narrate "Helmet unequipped!"

    Any idea on what's wrong ?
     

Share This Page