Solved Developing a plugin help

Discussion in 'Spigot Plugin Help' started by DoubleError, Aug 15, 2019.

  1. Hey guys I know most of you may find this annoying but I'm new to making plugins like just started today and can't seem to find out why the plugin won't load in my server this is the error I'm getting

    Error - https://pastebin.com/B7S3k7bP

    Thanks in advanced
    ~ DoubleError
     
  2. 14.08 20:35:37 [Server] INFO org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/doubleerror/plugin/Main has been compiled by a more recent version of the Java Runtime (class file version 56.0), this version of the Java Runtime only recognizes class file versions up to 52.0

    You need to compile with a lower version of Java. use a 1.8.0 variant.

    Don't take this in the wrong tone, but sometime reading the Stacktrace from start to finish helps.
     
  3. Nah I didn't take it wrongly I'm just new I read it I just didn't understand it like I said so how would I compile with a lower would I use JavaSE - 11 instead of JavaSE - 12?