Spigot DiceFurniture Plugin / Möbel Plugin 3.7.0

Furniture, ArmorStand, ProtocolLib, FurnitureLib, Möbel

  1. I'm on 1.17.1 with protocolib build 531 but DiceFurniture is not loading:

    [DiceFurniture] Enabling DiceFurniture v3.5.0-dev-5ec58e2f
    [DiceFurniture] [DiceFurniture] Plugin disabled because FurnitureLib is incorectly installed!
    [DiceFurniture] Disabling DiceFurniture v3.5.0-dev-5ec58e2f
     
  2. that didn't help look what is wrong with FurnitureLib!
     
  3. I'm using latest dev build of dicefurniture furniturelib and protectionlib
     
  4. please attach your latest.log to https://paste.gg/ or something else paste side otherwise i can't help you!
     
  5. Sorry if this a dumb question, but I can place furniture and use it fine but other people can't, how do I set it so if I place a chair everyone can sit on it?
     
  6. give your people the right permissions: https://dicecraft.de/furniture/newPerms.php
     
  7. I have the plugin on 1.16 and yesterday installed on 1.17, but it just spawns a pig for instance. So not sure whats wrong? It works on 1.16 and I love it.
     
  8. make sure you update your protocollib aswell
     
    • Agree Agree x 1
  9. Hi, I use the plugin in my world and it is very cool, but I only have one drawback, the large furnitures are half erased when I remove them, example, the flag when I delete it only removes the part of the block, but not the rest, Thank you and I wait for an answer. Vesion 3.5.0 Server 1.14.4
     
  10. Thanks for the response. Yeah I have updated that too, also Paper, cause I was out of ideas, but still no luck. And I see others are using it on 1.17, so it has to work, but I dont know why not for me.
     
  11. I am having an issue where I can place furniture, sit down on chairs, etc. However, I cannot dye sofas, beartraps do not activate, weapon racks do not work, etc. I tried reinstalling each of the plugins at the latest versions, updated spigot, but nothing seems to be working. My server is 1.14.4, do you know what's going on?
     
  12. Moin, im Moment gibt es das Problem, dass furnitures mit dem Filter "player" nicht richtig removed werden. Das plugin sagt dann einfach "Remove #SIZE# furniture models" (auch wirklich so mit dem Placeholder in der message) und lässt jene einfach da. Ein Restart jedoch hilft, dass es wieder funktioniert. Starte ich den Server danach allerdings wieder neu, kommt das o.g. Problem wieder. Könntest du das vielleicht fixen? Nehme nicht an dass das gewollt ist ;)
     
  13. Schau mir das Problem mal morgen an danke, mit der neuesten Version FurnitureLib?
     
  14. Ja genau, mit der neusten Version :)
     
  15. Irgendwelche Error in der Konsole?
    Kann nicht bestätigen das es durch die neueste DEV Version weiterhin vorhanden ist.
     
    #3418 Ste3et_C0st, Oct 24, 2021
    Last edited: Oct 24, 2021
  16. Ich habe leider keinen Error in der Konsole stehen. Was mir aber aufgefallen ist, dass wenn keine furnitures platziert wurden die selbe Nachricht kommt (also die wo nur der Placeholder #SIZE# steht), wobei da ja dann auch 0 stehen müsste. Gesetzt den Fall dass der command dann funktioniert und ich mind. 1 furniture gesetzt habe, steht da auch dass 1 removed wurde. Scheint also so, wenn der command nicht funktioniert, dass die furnitures nicht erkannt bzw. dem Spieler nicht zugeordnet werden.
     
  17. Deswegen frag ich ja so doff ob du die neuste DEV Version verwendest, dieß scheint nämlich tatsächlich nicht der fall zu sein, da in der DEV (welche überings 2 Versionenen hinter der letzten Offiziellen Version) ist bereits der Fehler mit dem #SIZE# zu 100% bei /furniture remove entfernt wurde, bitte überprüfe es nochmals das du auch wirklich die Version aktualisert nutze dafür gerne ein /furniutre dump oder schau in die Konsole.
    Wenn ich immer weiter an dem Fix arbeitest du allerdings nicht Updates kommen wir niemals auf einen gemeinsamen Nenner.