duplication glitch 1.12

Discussion in 'Spigot Help' started by slaapkopamy, Nov 22, 2017.

  1. Hi,

    If there a fix for duplication in 1.12? people get keys duplicated and i keep there banning... but i don't know how to resolve this problem on my server. can someone help my to solve?
     
  2. I think one of @Chazmondo 's plugins has an anti duplicate. If not, there's another one out there which I've seen.
     
    • Agree Agree x 2
  3. Celebrimbor

    Patron

    Update to 1.12.2.
     
    • Agree Agree x 1
  4. hi, i don't go update to 1.12.2 because there is duplication glitch too. So it doesn't solve the proble,
     
  5. I try it now out. I hope is now fixed
     
  6. Celebrimbor

    Patron

    Please show the community this 1.12.2 dupe. I think you might be mistaken.
     
  7. in I hope you know that in every update a new dupe is?

    I have tried blocked german ip adresses via litebans but that doesn't work...
     
  8. I have tried this plugin but people can some how duplicate everything including with voting they get 22 million keys...
     
  9. from testing, it just seems to create ghost blocks?
     
  10. md_5

    Administrator Developer

    That's a client side duplication.
    If you relog it disappears.
     
  11. I suggest using chazmondo's patch as well.
    1.12.2 still has armor/tool duplication glitches. I can record a quick video if you wish.
     
  12. show how if you can
     
  13. Once we updated our server to 1.12 we had found this dupe glitch on accident:

    This glitch worked in both 1.12 as in 1.12.1 & 1.12.2. on both regular spigot & paperspigot.
    At this point I asked @Chazmondo to add this fix to his 1.12 patch plugin and this is when we started testing how to prevent it and Chaz came up with a fix for it. The last time I tested this without chaz's patch I was only able to dupe tools/armor and I assume any unstackable item in the game would have worked as well.

    Basically what you want to do is shift-click the item out of the dispenser on the same time it shoots out from the redstone signal. this often gives a visual only dupe only but often you can also manage to get a full dupe as shown in the video above.
     
    • Agree Agree x 1
  14. Celebrimbor

    Patron

    Any duplication done in creative mode is not valid as a bug since the ghost items are assumed safe in creative(causing the "dupe"), but this does not occur in survival. If you do that in survival, the items will poof if you try to equip or relog.

    If I am wrong, please make a video in survival mode and equip the gear and relog. Then I'm sure developers will rush to the rescue.
     
  15. Should I mention that my server was a survival server and this dupe was reported by a player in survival mode? I tested this in both creative & survival mode, both worked just the exact same. I'm not here to convince you that this is a working glitch or not. I'm 100% sure this works or at least worked in some 1.12.2 version of spigot. This resulting me in answering @slaapkopamy warning her/him about this glitch and suggesting to use Chaz's patch to make sure it doesn't allow players to dupe items as I worked with Chaz together to fix this exact dupe glitch. ;)

    EDIT: if you are in survival mode it will dispense the armor on your armor slots inside your inventory. If you don't have armor equiped. This will cause the dupe glitch to not work in survival mode.
     
    #16 SirKillian, Dec 4, 2017
    Last edited: Dec 4, 2017
    • Agree Agree x 1
  16. I'm unable to replicate this, even in creative the duped item dissapears on the latest version of spigot.
     
  17. That could be correct. I did not test this on latest spigot nor paperspigot, which I might have should before starting the discussion.
     
  18. just tested 1.12 vanilla single player, in survival, and the second item just ghosted.
     
  19. electronicboy

    IRC Staff

    are you able to actually replicate this without plugins? We got the report for this on Paper too, but were unable to replicate whatsoever without plugins, when I had plugins on the server however, it was a different matter and I managed to actually pull this one off, leading me to believe that it's more than likely down to plugins and the blockstate API changes in 1.12