Spigot Dynmap v3.1-beta-2

Dynamic 'Google Maps' style web maps for your Spigot/Bukkit server

  1. From Mikes Redit link ....
    Main support thread: https://www.reddit.com/r/Dynmap/ - please direct questions here
    Issues/Bugs/Features: https://github.com/webbukkit/dynmap/issues

    ---------------------------------------------------------------------------------------------------------------------------
    Spigot 1.16.1 Support Status

    [​IMG]
    "I'll be using this post to report status on support for 1.16.1 Spigot - I will not be responding to any other posts, nor chats, on the matter, so don't bother :)

    1. Current build will not run on Spigot 1.16.1 - so don't expect 3.0.1 to be usable

    2. I'll be trying to get a 'running' version available first - once that is the case, it will probably NOT have support for the new 1.16.1, so I'll not be interested in hearing about that.

    3. Once I do have a 1.16.1 build which both runs and includes, what I believe to be, support for the 1.16.1 blocks, I'll be releasing it as 3.1-beta-1. Once this is the case, I'd both consider it (reasonably) safe to run AND something I care to hear about, as far as bugs and the like.
    Stay tuned here - I'll be adding edits below as things progress!"
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Thanks Mike - To everyone else stay tuned - via Redit - DaDMaR777
     
    #1161 DaDMaR777, Jun 26, 2020
    Last edited: Jun 26, 2020
    • Like Like x 7
  2. This was taken from the official Dynmap reddit
    ------------------------------------------------------------------------------------------------
    Edit 3: OK - here's a development build - https://dynmap.us/builds/dynmap/Dynmap-3.1-SNAPSHOT-spigot.jar-

    • It does not have about 1/2 the new blocks, so if something renders wrong, I don't care about that yet :)

    • Don't run this on anything except a disposable 1.16.1 server - it might very well break on 1.15.2 or earlier, and it certainly does nothing better than 3.0.1 on those servers

    • Don't put this on production. If your server crashes or otherwise is messed up, don't say you were not warned!

    • Do let me know if it does crash your server, or if functions other than the rendering of the new blocks are broken!
    I'm shooting to get to a beta build, with all new blocks done, by tomorrow sometime.
    ------------------------------------------------------------------------------------------------
    Updated post -> Click here -> via Reddit -> mikeprimm
     
    • Like Like x 4
  3. mikeprimm

    mikeprimm Retired Developer
    Retired

    mikeprimm updated Dynmap with a new update entry:

    Spigot v1.16.1 support added

    Read the rest of this update entry...
     
    • Like Like x 1
    • Winner Winner x 1
    • Friendly Friendly x 1
    • Like Like x 1
    • Winner Winner x 1
  4. I'v notice that Dynmap when rendering worlds makes the rendered world look really low resolution. Let me show you what I mean.
    Dynmap 1.16 -----> DynmapGrannie1.PNG

    Dynmap 1.15 ------> DynmapGrannie2.PNG
     
    • Funny Funny x 1
  5. Hello,
    The default render is jpeg. Not png anymore.
    You need to edit your config file according your preferences.
    Look for "image-format:"
     
  6. Why dynmap does that when migrate-chunks is enabled? This is a 1.12.2 map on a 1.16.1 server [​IMG]

    and I know support is on reddit but I'm not posting there

    EDIT: atleast fix the issue with converted chunks not being rendered at all
     
    #1168 TNTUP, Jul 16, 2020
    Last edited: Jul 23, 2020
  7. Edit: Nevermind it looks like it has disappeared today without me doing anything more than the below and just took some time to update for some reason.

    I'm seeing two "Spawn" points on my main world on dynmap, I've done the following but still seeing it:

    Code (Text):
    /mv setspawn (for Multiverse)
    /setspawn (for Essentials)
    /setdefaultspawn spawn (for HomeSpawnPlus)
    /setworldspawn (for Minecraft)
    I've even set showspawn in configuration.txt to false:
    Code (Text):
        # (optional) add spawn point markers to standard marker layer
        showspawn: false
        spawnicon: world
        spawnlabel: "Spawn"
    And the coordinates in markers.yml
    Code (Text):
                marker_2:
                    world: world
                    markup: false
                    x: 42.0
                    icon: world
                    y: 73.0
                    z: 246.0
                    label: Spawn
    Can anyone advise what else I might need to do?

    I'm running Paper Spigot.

    Edit: Nevermind it looks like it has disappeared today without me doing anything more than the above and just took some time to update for some reason.
     
    #1169 Zippyduda, Jul 25, 2020
    Last edited: Jul 26, 2020
  8. mikeprimm

    mikeprimm Retired Developer
    Retired

    mikeprimm updated Dynmap with a new update entry:

    Dynmap v3.1-beta-2

    Read the rest of this update entry...
     
    • Like Like x 1
  9. If I enable login, can the plug-in share login data with "Authmereload"
     
  10. hey. I was wondering if anyone can help me out. I want to add my dynmap to a custom domain. i already brought the domain but now i need to add the dynmap URL that it gives me, i tried to look online and on youtube but i i can't find anything that helps me. i was hoping someone here could
     
    • Like Like x 1
  11. This might be helpful: https://github.com/webbukkit/dynmap/wiki/Setting-up-without-the-Internal-Web-Server
     
  12. Question: Does anyone know how to adjust the compass in the top right corner of dynmap so that it follows the iso_SE_30_hires perspective?
     
  13. Hey, first time posting. I was wondering if anybody could help me with my situation: I had dynmap running and functional on my hamachi server but I decided to move from hamachi to a port forwarded server. Everything from the world transferred over smoothly except for dynmap. I can't seem to connect to the map using my new ip nor my old hamachi ip. I've tried reinstalling and reloading the plugin. Any help would be appreciated. Thank you.
     
  14. Please add .webp support and something to convert everything to .webp :) only apple users don’t support this yet (ios 14 and big sur does) but file sizes are a lot smaller and quicker.
     
  15. I had disabled the reading of the game chat on the dynmap website. Since the last update it can be read from the web but I have it disabled in the configuration.

    Who helps me?
     
  16. Hello there,
    I can't render a map that I uploaded to the Multiverse in the Dynmap....
    I tried a lots of time, and find my developers to help, but still not working TwT
    The map that I want to render in Dynmap is the map that I prerender in a Test server, which is version 1.13.2, I fully rendering the whole world by using WorldBorder in the test server, but after I upload the files back to my main server, which is version 1.15.2, the map can be loaded, but in the dynmap, it only shows one chunk, which is really small... I try to use /dynmap fullyrender CityWorld, not working... And then, I try to use /wb fill, it crashed my server for a few time but luckily still success to render.... But still, the Dynmap shows nothing on the map QwQ Me and my developers try a lots of way, but still not working TWT We also try delete the plugin and then dynmap render again, but still not working TwT QwQ
    What should I do? QwQ
     
  17. Question for you, when you use world border to auto load the chunks, did you upload that world folder back to your main server?
     
  18. Yes I have...