Spigot eBackup - Simple and reliable backups for your server! Supports FTP/SFTP! 1.2.0

The easiest and simplest way to backup your server reliably! Free, and supports FTP+SFTP!

  1. Add the other files that are not the worlds to the "ignore" list:

    Ex.
    Code (YAML):
       
        pluginjars
    : false # The .jar files for the plugins
        pluginconfs
    : false # The data folder of each plugin
        ignore
    : # Files to ignore and NOT backup
            - 'plugins'
            - 'logs'
            - 'cache'
            - 'banned-ips.json'
            - 'crash-reports'
            - 'banned-players.json'
            ...
     
  2. Could you give me the error you are getting?
     
  3. It would be nice to have an option to choose between the art of saving - zip or normal.

    Btw very good plugin, thank you so much ;)
     
  4. Hey! I'm having a very strange issue. I run /ebackup backup. The resulting .zip file is 2.1GB, but the "world" folders are nowhere to be found. The total size of all files in the archive are 150MB - but the archive itself is 2.1GB. It looks like the world should be in there, but the files are missing. They're also not hidden files.

    This is true in every backup over dozens of copies. What should I try from here? The config file is proper - configured as stock, save for the cron.

    # What you want in the backup.
    # By default, everything will be backupped, you can remove folders in the ignore section​

    backup:
    pluginjars: true # The .jar files for the plugins
    pluginconfs: true # The data folder of each plugin
    ignore: # Files to ignore and NOT backup
    - 'plugins/eBackup/backups'
    - 'plugins/dynmap'
    - 'logs'
    - 'cache'​
     
  5. An update - if I extract the .zip archive, the file size drops to 150MB. But all the .zip files are 2.1GB otherwise, for every backup - but the World folders are nowhere to be found. Now I'm really confused.
     
  6. Sorry for the delay, did not see this message. I remember this being an issue on viewing backups in Windows with versions < 1.0.4. Are you running the latest version?

    If you wanted to find the world from old backups, open it with a Linux zip archiver. Otherwise, newer version of the plugin should have the issue fixed.
     
  7. Hi. Very good plugin and very usefull. I tried to use another folder for the backup and i got tan error. The folder is "/home/minecraft/crafty/crafty-web/backups" (instead of "/home/minecraft/server/plugins/eBackup/backups") that is the backup folder of the launcher that i use. Task is little buggy so i decided to use a plugin instead for my backups. I mount a 2nd disk to put my backup on it so the path "/home/minecraft/crafty/crafty-web/backups" is on my 2nd disk. Sorry if it's not 100% clear i speak french.

    Here's the error:

    [19:54:27] [Craft Scheduler Thread - 17/INFO]: [eBackup] Starting backup...
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: java.lang.NullPointerException
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at dev.espi.ebackup.BackupUtil.checkMaxBackups(BackupUtil.java:43)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at dev.espi.ebackup.BackupUtil.doBackup(BackupUtil.java:75)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at dev.espi.ebackup.eBackup.lambda$onCommand$1(eBackup.java:146)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at org.bukkit.craftbukkit.v1_15_R1.scheduler.CraftTask.run(CraftTask.java:84)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at org.bukkit.craftbukkit.v1_15_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:54)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at com.destroystokyo.paper.ServerSchedulerReportingWrapper.run(ServerSchedulerReportingWrapper.java:22)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
    [19:54:27] [Craft Scheduler Thread - 17/WARN]: at java.base/java.lang.Thread.run(Thread.java:834)
     
  8. Could I have your config please (on Pastebin)
     
  9. I put back the original line and comment mine to have the plugin working.

    https://pastebin.com/XpFRHLEv
     
  10. add a / before home
     
  11. Thank you. It works. i didn't put a / because the original path didn't have one. But i understand why i need to put one.
     
  12. Regarding not being able to see the world folders. That's such a weird bug/issue from windows' end. unzipping the file shows the worlds no problem. everything working flawlessly.
     
  13. Yes, it was fixed in an update a few months ago, please update your plugin version. I have more context in my previous reply.
     
  14. Hi, could you support for Zip files compress level adjustment? and 7zip format support?
     
  15. I am using the newest version of the plugin. im just assuming i need to update windows on my end.
     
  16. well 7zip supports zip, and it's universal. I believe the compression level is at its highest (I think, I can't really remember)
     
  17. Hey! Sorry, I checked for the first few days then it fell off my radar.

    Still have the issue, yes! I'm using 1.1.0 right now. No world files show in backups. I opened it with another .zip extractor, and now I see the world files, but NOT in the typical folders. This is my backup .zip directory: "C:\Minecraft Server\plugins\eBackup\backups\eBackup 2020-05-20 12-00-00.zip"

    The world files are here: "C:\Minecraft Server\plugins\eBackup\backups\eBackup 2020-05-20 12-00-00.zip\.\world

    They're in a folder named ., which is an invisible folder. Windows doesn't see it nor is it able to extract it. Could this possibly be fixed? And again, yes - I'm using 1.1.0!
     
  18. Strange, I will be checking it out later. Are you using 7zip?
     
  19. I want to backup every 20 minutes. How can i do it?