1.16.1 Eclipse does not autocomplete spigot methods

Discussion in 'Spigot Plugin Development' started by Fliens, Aug 2, 2020.

  1. Hi,

    I wanted to update my plugin to 1.16 but since some time went by when i started developing the plugin i forgot where i could get the spigot api. So I tried it with the BuildTools and with Nexus like it's adviced in this post https://www.spigotmc.org/wiki/creating-a-blank-spigot-plugin-in-eclipse/?noRedirect=1
    but when i add the jar to the project (properties>java buld path>libraries) it says that everything is fine and it also compiles bit when I try to write something new or when I try to use methods from spigot it wont show me them. (ctrl+space says that there are no functions for onEna for example)
     
  2. Does the plugin get loaded by the server if you export it as a jar and put it in the plugins directory?
     
  3. it does
     
  4. Sounds like the dependencies got messed up somehow. Try deleting the caches if Eclipse can do that. Another (maybe) fix would be trying Gradle/Maven to see if that fixes it.
    Also could come to the sark side and swap to IntelliJ.