Eclipse export issue

Discussion in 'Spigot Plugin Development' started by Markyroson, May 31, 2017.

  1. Every other time I export my plugin using the latest version of eclipse, it exports an old cached version from weeks ago that had a fatal plugin.yml error (ZipException/Invalid plugin.yml). No matter how many times I "refresh" or "clean" before exporting. I have tried exporting it twice (and overwriting) and that does not even work. The only way it seems to properly export is when I run the failed one in a test server and then export again and overwrite within the plugins directory.

    It is annoying and time consuming but nothing else seems to work. Has anyone else run into this issue (or similar)? Any suggestions? Is there any way that I could simply delete the cache and force it to export the latest version every time?

    Thanks in advance for your help! :D
     
  2. post here your plugin.yml
     
  3. Here it is in full @fernandopal :
    Code (Text):
    name: ServerTP
    main: me.Markyroson.ServerTP.Main
    version: 1.92.2
    description: "Adds teleportation functionalities to servers that this plugin is installed on"
    author: Markyroson
    commands:
        sethub:
            description: "Sets the hub"
            permission: ServerTP.sethub
        hub:
            description: "Teleports you to the hub"
        st:
            description: Displays full list of commands
            aliases: [servertp, stp]
        setpark:
            description: "Sets the theme park"
            permission: ServerTP.setPark
        themepark:
            description: "Teleports you to the theme park"
        shop:
            description: "Teleports the player to the shop (if set)"
            permission: ServerTP.shop
        setshop:
            description: "Sets the shop"
            permission: ServerTP.setshop
     
  4. Your main class is on "me.Markyroson.ServerTP.Main"?

    And remove the quotes from "description" I do not put them, I do not know if they will be optional.
     
  5. Removed the quotes. My main class is indeed there. As I say, the yml and plugin is completely valid, I appear to have some sort of a weird caching issue with Eclipse from an old version of the plugin (that was legitimately broken) from a couple weeks ago. Any idea how to clear the cache? @fernandopal
     
  6. 1) Try exporting to an other location.
    2) Try if a other project has the same problem when exporting.
    3) Reinstall eclipse?!
    4) Well... You shouldn't come to this option.

    That shouldn't matter. When you're exporting it eclipse just packaging it into a .jar, not checking every kind of thing if it's correct... Bukkit will, that's why you get those stacktraces :)
     
  7. Tried a different location, same result. I do know that other projects do not have this issue as I am working on another project as well and it exports just fine. I already essentially tried reinstalling eclipse by upgrading from keplar to the latest version.

    Should I try deleting the .bin and/or .settings folders in the project (seen when using file explorer or whatever it is called)? @NormaalBart @fernandopal
     
    #7 Markyroson, May 31, 2017
    Last edited: May 31, 2017
  8. @Markyroson make a back-up of the folder, copy it into a folder or something, and delete those files. I think it won't care but you've to try it I gues..
     
  9. You are correct. It also appears to have the issue where if I attempt to unload and then reload a working version of the plugin (that loaded the first time) it produces the same error as a failed build and won't load after that. It is a weird situation I have here. Again, it does it regardless of if quotations are present in the plugin.yml. @NormaalBart