Spigot EggCatcher 5.0

Catch mobs with eggs

  1. I've got a function for that, if the plugin owner wanna use it :

    Code (Java):
    public static String colorize(String string) {
    return org.bukkit.ChatColor.translateAlternateColorCodes('&' string);
    }

    // Use :

    if (playerArgs == null) {
          sender.sendMessage(colorize(Other.replacePlaceHolders("&aIncorrect!")));
    }
     
    • Useful Useful x 1
  2. Thann you Nice plugin
     
  3. Hello,

    It is possible to disable the catch in specific worlds?
     
  4. I tried to analyse the horse problem with 1.13 but failed to get the source code.
    (from the referred location: https://github.com/shansen/EggCatcher )
    The repo seems outdated and I couldn't find current sources. Could you please update the repo or point me to the correct repo?
     
  5. Is anyone else able to catch mooshrooms with this plugin? I've tried, and cannot. (Both an OP person, and a non-OP with the permission
    eggcatcher.catch.*)

    Minecraft Version: 1.13.2
    EggCatcher version: 4.2

    Config: https://pastebin.com/V5G6Ju0Y
    Error when I try to catch a mooshroom: https://pastebin.com/gJgGzxPi

    Edit: This also happens with Zombie Pigmen.
    Error: https://pastebin.com/CzCpBLJ1

    Thank you to anyone with suggestions!
     
    #105 Diamond_Cat, Dec 31, 2018
    Last edited: Jan 2, 2019
  6. @Endothelium: Enabling Eggcatcher per World could be achieved with world-specific permissions (PermissionsEx supports that).
     
  7. The following provided mob's nodes don't work: mooshroom, zombie pigman, rabbit, wolf, and horse (and possibly a few others).

    Not having much luck yet with rabbit, wolf, and horse... but use these nodes for mooshroom and pigman instead. They will work for now (but once the plugin is updated, you will want to check the dev's supplied nodes and change accordingly.)

    Mooshroom - eggcatcher.catch.mushroomcow
    Zombie Pigmen - eggcatcher.catch.pigzombie

    For the dev, I think the egg catch listener should be using the EntityDamageEvent method getEntityType() to pull in the correct mob names, instead of getEntity(), which would explain why the pigman and mooshroom perms above work.
     
    #108 VitaMC, Jan 17, 2019
    Last edited: Jan 17, 2019
    • Useful Useful x 1
  8. Very helpful, thank you! I am now able to negate those permissions, so at least people won't destroy their mooshrooms/zombie pigmen in an effort to catch them.

    (I still cannot catch them, of course, because it wasn't a permissions issue - it's the same error for an OP person and non-OP - but this is very helpful ^.^)
     
  9. It seems that if this plugin does not recognize a mob, it destroys it when an egg hits it. For example, withers, snow golems, and iron golems. None of these are on the permissions list, so I don't expect to be able to catch them. However, I don't think it should destroy the mob..

    Here's my error for a snow golem: https://pastebin.com/beE6JRnB

    Server version: 1.13.2
    EggCatcher version: 4.2
     
    • Like Like x 1
    • Agree Agree x 1
  10. Are you using an old version of spigot? This looks like you're using 1.12 and i assume that EggCatcher 4.2 only works with 1.13.2.
     
  11. I have the same issues in 1.13.2, at least with some mobs (not all), so it's not just a 1.12 issue. If it happens with all mobs, it might be a 1.12 issue for him.
     
  12. Yeah I am using 1.12. But why does it then say its tested on 1.12 xP

    *EDIT* I've got the right version now ^^
     
  13. Updating to 4.2 allowed me to finally catch magma cubes and polar bears, but zombie pigmen are uncatchable. Already reported by VitaMC but seconding an issue never hurts.
     
  14. Could you add an option in the config to not save the mob's name, upon being "egg"d?

    We use EggCatcher, MythicMobs, and ProRecipes. We'd like for our users to catch a Skeleton (named Lv22 Skeleton, for example) and create a Mob Spawner with this egg using ProRecipes. However, because the egg is saving the mob's name, Lv22 Skeleton, ProRecipes does not recognize it as a mob name.
     
  15. I'm getting this error when a player hits another player with an egg (or hits themself with an egg). https://pastebin.com/bHarw5Wb

    If a player is hit with an egg, they are muted. They cannot send commands or chat messages until they relog. This does not happen if they have no permission to catch any mobs, but if they have permissions to catch a single mob or more (I tested by giving them only the permission to catch bats), this happens.


    [​IMG]

    Server Version: 1.13.2
    Plugin version: 4.2

    Thank you to anyone with suggestions on how to fix this!
     
  16. I'm having issues with this plugin, everytime I try to catch an animal, I get this in the log, and I'm not sure what it means.

    This is what my config file looks like, I'm using version 4.2 in Minecraft 1.13.2

    In the log above, I attempted to catch a pig, which have a 50% catch rate, I had 7 eggs, and used all 7 and only got 4 messages saying the catch failed, the 3 times it should have caught it are in the log above.
     
  17. My players and I are not able to catch horses, wolves, mooshrooms, and I think a couple other mobs.
    I seem to have the latest version of the plugin, but I dont know how to check the version.
    How can I check to ensure I have the most recent/updated version?
    Is there any way I can fix this via config?


    - Thanks

    We're on 1.13.2
    Spigot
     
  18. I can't help with your issues catching mobs, sorry. I've had several issues myself.

    But, to check the version of the plugin you're using, you can use /version eggcatcher
    (This works for other plugins, too, just replace eggcatcher with the name of the plugin)
    To see if it's the latest version, compare it to the number on the top of the plugin page (or the version history).