1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Elevator in SMP No Longer Works Since Last Spigot Update

Discussion in 'Bugs & Feature Requests' started by indianajones, May 9, 2013.

  1. Not sure if this has to do with a bug with redstone timing or pistons; however, I am observing a bug with an elevator I built in a SMP that was once working until the latest Spigot update.

    How do I know?

    I replicated the issue on my own build of a local Minecraft server as found in the steps I took below:
    • I downloaded the Minecraft 1.5.2 server and installed it.
    • I installed this elevator world: http://www.mediafire.com/?q9v7pb2zlawvrgy
    • I then started up my local server without any other plugins and checked that the elevator worked just fine.
    Next, I downloaded the latest version of Spigot, which is what my friend's server runs and then started the elevator again, and in this 2x2 elevator, some pistons either go up or down 2-3 spaces and stop, thus rendering the elevator broken.

    Don't believe me? Follow the aforementioned instructions and you will see for yourself.

    Please help!
     
  2. "Latest" is not a version. Next time, please refer to the proper build number. If you don't know, you can always run /version ingame or through the console.

    Anyways, have you tried replicating this with CraftBukkit?
     
  3. #3 indianajones, May 9, 2013
    Last edited: May 9, 2013
  4. Ok, I have replicated this issue with CraftBukkit with different results and here is the screenshot of the version of CraftBukkit installed:

    [​IMG]

    What is interesting, is that with Spigot, the pistons will push in different directions 2-3 spaces. With straight CraftBukkit, what should go up, all four pistons push all the way down.
     
    #4 indianajones, May 9, 2013
    Last edited: May 9, 2013
  5. mikeprimm

    mikeprimm Retired Developer
    Retired

    Your title suggests that it worked sometime before "the last spigot update". Could you confirm or deny that? Your text seems to suggest it worked on vanilla 1.5.2, works one way with Spigot #849, and works another way with CB #2774 - I don't see a statement of it working differently on a specific earlier spigot.

    Edit: Also, since the CB you tested is out of sync with the Spigot, could you try with the corresponding 'latest CB' (so that we're comparing CB-without-spigot-mods to the same CB-but-with-spigot-mods)? Main point here is to see if any recent changes - Spigot or CB - actually affected this, or is this a vanilla-vs-CB behavior difference (recent or otherwise), or a CB-versus-spigot behavior difference. Any time you talk about pistons (the single biggest source of dup exploits), its possible that there are CB fixes for vanilla dup issues that may translate into subtle behavior changes - which may or may not be able to be corrected while preserving the more-important dup fix.
     
    #5 mikeprimm, May 9, 2013
    Last edited: May 9, 2013
  6. P-T

    P-T

    Hi there, server owner of "friend's server" here.

    This worked properly on Spigot 1.4.7-R1.0-y (#617). It stopped working since the 1.5.x versions. I'll let Indianajones provide more details.
     
  7. LiLChris

    LiLChris Retired Moderator
    Retired

    So that is why my entire creative server has been complaining and yelling bloody murder.
     
    • Agree Agree x 2
  8. mikeprimm

    mikeprimm Retired Developer
    Retired

    Only relevant data points right now are 1.5.2 vanilla versus current 1.5.2 CB versus current 1.5.2 spigot. If it works with vanilla 1.5.2, its worth discussing - if not, its not something we'll likely look at - the fact is that Mojang changes behaviors in a way that breaks these things pretty regularly. If CB broke it, we may be able to fix it - but no promises. If Spigot broke it, relative to CB, we're definitely interested.
     
  9. What data point is missing? If its the latest version of CB, which version do you want me to try, because I thought I did that?

    Here's the breakdown on data points:

    Data Point #1: It works in 1.5.2 vanilla
    Data Point #2: It does not work with 1.5.2 current version of spigot (see above for version).
    Data Point #3: It does not work with 1.5.2 CB current version (see above for version).
     
  10. mikeprimm

    mikeprimm Retired Developer
    Retired

    I misread the cb version you posted as 1.5.2-R0.1 versus 0.2 - probably need to start by reporting it to the CB guys, if you haven't already. Leave out any mention of Spigot if you want any chance that they'll do anything.
     
  11. Thanks, I will check with the CB folks and report back the results, if interested.
     
  12. P-T, how do I learn which version of CB supported Spigot 1.4.7-R1.0-y (#617)?