Bukkit Empires 1.1.1

Empires is a land and group relation management system focused on granular control.

  1. pixelgriffin submitted a new resource:

    Empires - Empires is a land and group relation management system focused on granular control.

    Read more about this resource...
     
    • Like Like x 1
  2. I now know what type of server I am going to make! Thank you! <3
     
    • Friendly Friendly x 1
  3. Hi plugin author,
    Thanks for making such a great plugin. Is it ok if you add a list of plugin dependencies as I have trouble getting it to be installed onto my server, thank you.
     
  4. Thanks for you message,

    I see that I have accidentally set the "useVault" and "useHerochat" to true as default in the config.yml.

    There are soft-dependencies on Vault and Herochat. However, if you don't want to integrate with either of these plugins you can set "useVault" and/or "useHerochat" to false in the config.yml.

    I have fixed this issue and am currently uploading a new version.

    Thanks!
     
  5. pixelgriffin updated Empires with a new update entry:

    Soft-Dependencies Config Fix

    Read the rest of this update entry...
     
  6. Awesome, thanks for the update. May I ask if you're able to make a chat tag that will allow us to show the player's kingdom or Empire in another chat such as EssentialsChat, Thank you. I also had a look at the source codes provided and from what I could recalled, tagAPI was also a dependency (Please correct me if I'm wrong).
     
  7. Yes, I will look into adding EssentialsChat support over the weekend!

    TagAPI was supported quite a long time ago, but unfortunately is not at the moment. The latest update has removed the TagAPI soft-dependency from the plugin.yml and config.yml. TagAPI is no longer supported by the author as I understand.

    Thanks!
     
  8. 18.09 11:11:48 [Server] ERROR Could not load 'plugins/Empires.jar' in folder 'plugins' 18.09 11:11:48 [Server] INFO org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/dthielke/api/Channel 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:297) [spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:202) [spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:539) [spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66] 18.09 11:11:48 [Server] INFO Caused by: java.lang.NoClassDefFoundError: com/dthielke/api/Channel 18.09 11:11:48 [Server] INFO at java.lang.Class.forName0(Native Method) ~[?:1.8.0_66] 18.09 11:11:48 [Server] INFO at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_66] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO ... 6 more 18.09 11:11:48 [Server] INFO Caused by: java.lang.ClassNotFoundException: com.dthielke.api.Channel 18.09 11:11:48 [Server] INFO at java.net.URLClassLoader.findClass(URLClassLoader.java:381) ~[?:1.8.0_66] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_66] 18.09 11:11:48 [Server] INFO at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_66] 18.09 11:11:48 [Server] INFO at java.lang.Class.forName0(Native Method) ~[?:1.8.0_66] 18.09 11:11:48 [Server] INFO at java.lang.Class.forName(Class.java:348) ~[?:1.8.0_66] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3] 18.09 11:11:48 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.10-R0.1-SNAPSHOT-latest.jar:git-Spigot-6016ac7-10c10b3]
     
    #9 franckjohann, Sep 18, 2016
    Last edited: Sep 18, 2016
  9. What version of Herochat are you using? Can you link me to it?

    Edit: Only Herochat 5.7.0+ is supported
     
  10. I'm not using herochat , it is mandatory ?
     
  11. It is not mandatory. By default Herochat integration should be off. If you wish to use it just change useHerochat to true in the config.yml.
     
  12. herochat installed , but the problem is that the server loads the plug empires , the server does not start it plugin
    My inglesh is bad, sorry.
     
  13. Is "useHerochat" set to true in your config.yml file? If you don't Empires to use Herochat you can set that to false. If you do want it to use Herochat, it will only work with 5.7.0 right now.
     
  14. I did everything I said , the more the error discrito top still persists ... I can not open the configuration file , the jar file is not loaded ... I will await future updates to see if I can use the plugin , the plugin looks great!
     
  15. I keep getting this error:
    Code (Text):
    [13:54:51 ERROR]: Could not load 'plugins\Empires.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: com/dthielke/api/Channel
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[spigot.jar:git-Paper-819]
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:331) ~[spigot.jar:git-Paper-819]
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:254) [spigot.jar:git-Paper-819]
            at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:292) [spigot.jar:git-Paper-819]
            at org.bukkit.craftbukkit.v1_10_R1.CraftServer.reload(CraftServer.java:774) [spigot.jar:git-Paper-819]
            at org.bukkit.Bukkit.reload(Bukkit.java:556) [spigot.jar:git-Paper-819]
            at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:43) [spigot.jar:git-Paper-819]
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:152) [spigot.jar:git-Paper-819]
            at org.bukkit.craftbukkit.v1_10_R1.CraftServer.dispatchCommand(CraftServer.java:665) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.PlayerConnection.handleCommand(PlayerConnection.java:1389) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.PlayerConnection.a(PlayerConnection.java:1194) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.PacketPlayInChat.a(PacketPlayInChat.java:5) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot.jar:git-Paper-819]
            at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_101]
            at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_101]
            at net.minecraft.server.v1_10_R1.SystemUtils.a(SourceFile:45) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.MinecraftServer.D(MinecraftServer.java:791) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.DedicatedServer.D(DedicatedServer.java:404) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.MinecraftServer.C(MinecraftServer.java:725) [spigot.jar:git-Paper-819]
            at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:624) [spigot.jar:git-Paper-819]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_101]
    Caused by: java.lang.NoClassDefFoundError: com/dthielke/api/Channel
            at java.lang.Class.forName0(Native Method) ~[?:1.8.0_101]
            at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_101]
            at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:65) ~[spigot.jar:git-Paper-819]
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[spigot.jar:git-Paper-819]
            ... 21 more
    Caused by: java.lang.ClassNotFoundException: com.dthielke.api.Channel
            at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_101]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:102) ~[spigot.jar:git-Paper-819]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:87) ~[spigot.jar:git-Paper-819]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_101]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_101]
            at java.lang.Class.forName0(Native Method) ~[?:1.8.0_101]
            at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_101]
            at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:65) ~[spigot.jar:git-Paper-819]
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[spigot.jar:git-Paper-819]
            ... 21 more
     
  16. As with the previous person, please make sure you are using Herochat 5.7.0. Legacy support is coming but not currently available. In the event you don't want to integrate with herochat you can always turn off integration in the config.yml file.
     
  17. I would like to disable integration, but the config is not generating. Do you know why?
     
  18. Is that the case? I'm very sorry about that. I suspect that is what the last person what attempting to tell me too. This is a very serious issue and is linked with the error you are receiving. Give me a few minutes to make sure I have fixed this issue before uploading a new version.
     

Share This Page