Premium **ENABLED** NewItems [1.9-1.13.2] - Create items/blocks with custom texture/3Dmodel - WITHOUT...

Discussion in 'Resource Discussion' started by LoneDev, May 12, 2016.

  1. To everyone:
    Contact me via PM, it's easier to handle requests, thanks.
     
  2. This is impossible to fix. It's hard to change how vanilla minecraft recipes work and they are almost impossible to remove
     
  3. Understood, completely understood, and, yes, I am also an Expert Java Programmer, and having someone with similar experience can be hard to find in this community, especially noting most of the people here find their knowledge from YouTube videos and other such basics such as referring to an API.

    Unlike where I actually went through a proper education to learn my programming, and java was mostly skipped through since the language isn't as useful as many others, I'm just blabbering on now, have a good time developing your plugin. :)
     
  4. Nice words, thanks ;)
     
  5. @evilLamer quick question, are player by default able to craft everything? Or do they need ni.user.craft.<itemName>
    If they do need the permission node does ni.user.craft.* work?
     
  6. I have another plugin use diamond_hoe as item too. can I change newitems to use golden_hoe instead?
     
  7. Yep, it works if you have a good permission system (like PEX).

    It's not possible due to Minecraft limitations
     
    • Informative Informative x 1
  8. How to create new Amor?
     
  9. For now it's not an implemented feature
     
  10. Is this even working at 1.11.2 it is worth giving 29€ for something which is asking for dependency for resourcepackAPI which is actually only for 1.9-1.10 my question is. How do you guarantee that if I buy it. It will work in 1.11.2
    (Install ResourcePackAPI (Soft dependency). Only in 1.9-1.10 : Download Here)
     
  11. Yes it works in 1.11.2. Also if you are so worried wait until it's been developed further. There is still a lot to be done with this plugin, and he hasn't added half of what he wants to. I bought it so I could start making my own models, and using them as actual items.
     
  12. Hmm in description it written that it requirer ResoursePackAPI how its working on 1.11.2 when it says clearly "only 1.9-1.10" ?
     
  13. In one of the patch notes, he stated that he removed the requirement for resource pack api. Only in the latest versions though. So if you are getting the latest jar don't use resource pack api.
     
  14. Oh I havent see it okay then i will consider buying it soon i think :) Thanks mate
     
  15. Hi,

    I've been looking at your plugin for a while, since it was only a few dollars (words cannot express how much I regret not buying it then xD) and I've seen the plugin progress and I like what I see.
    I tried to buy it about three days ago, but when I clicked the buy button it would not let me continue. Do you know when you buy a Spigot plugin, after you click the buy button, an email/paypal button comes up to confirm "Yes, I want to buy this" well, that did not show up. The only thing that did was the standerd message telling you they are not responciable for it and your spigot can get banned for misusing it and so on.

    Sorry if that was confusing... I didn't know how to properly word that xD To put it simply, I can't buy the plugin, do you know why? Is it down? I would also like to point out this is how it is with all your plugins for me. So it is not limited to NewItems.

    If you can fix this, that would be amazing and I would buy the plugin the moment I saw it was fixed.

    Thank you,
    Draco
     
  16. What does this mean? [​IMG]
    I haven't edited the lore.
    Also I don't understand how to get blue honey or what the astral pickaxe does. Also, is it possible to make when a bee comes out of a flower, that it doesn't drop the flower?
     
    #596 Sequacious, Feb 15, 2017
    Last edited: Feb 15, 2017
  17. When will this be available to buy again D:
     
  18. I am glad to know I am not the only one experiencing this. (Sort of)
     
  19. Getting this error spammed on rotating any items in frames
    [00:43:25 ERROR]: Could not pass event PlayerInteractEntityEvent to NewItems v3.1.1
    org.bukkit.event.EventException
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:502) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:487) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.PlayerConnection.a(PlayerConnection.java:1527) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.PacketPlayInUseEntity.a(SourceFile:69) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.PacketPlayInUseEntity.a(SourceFile:13) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_74]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_74]
    at net.minecraft.server.v1_11_R1.SystemUtils.a(SourceFile:46) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.MinecraftServer.D(MinecraftServer.java:747) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.DedicatedServer.D(DedicatedServer.java:399) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.MinecraftServer.C(MinecraftServer.java:678) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:576) [spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_74]
    Caused by: java.lang.IndexOutOfBoundsException: Index: 1, Size: 1
    at java.util.ArrayList.rangeCheck(ArrayList.java:653) ~[?:1.8.0_74]
    at java.util.ArrayList.get(ArrayList.java:429) ~[?:1.8.0_74]
    at com.evill4mer.NewItems.I.b(Unknown Source) ~[?:?]
    at com.evill4mer.NewItems.b.b.b(Unknown Source) ~[?:?]
    at sun.reflect.GeneratedMethodAccessor672.invoke(Unknown Source) ~[?:?]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_74]
    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_74]
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:302) ~[spigot-1.11.jar:git-Spigot-4741400-c1aa859]
    ... 15 more
    I can list my plugins but it's a hell of a lot, just hoping it's an easy fix in NewItems itself