entity-activation-range removing item frames?

Discussion in 'Spigot Help' started by PirateCraft, Jun 16, 2015.

  1. I have had some high TPS due to extreme amounts of entries in my main world; the timings paste entities section when clicked says its safe to set the entity-activation-range to 4 from 16, I have had item frames start disappearing recently and this is all I can think that may be causing it.
    Would this cause it? if so whats a safe number to set this to? I was reducing it to remove clearlag from my server, but if I can't set it to just clear ground items I may have to re-enable the plugin.
     
    • Funny Funny x 1
  2. joehot200

    Supporter

    I doubt the activation range is the issue. The activation works like the following:

    • If any player is within activation range:
    • tick entity
    • If player is not in activation range
    • Only tick the entity once per second.
    All it's doing is processing the entity less. I don't see how this would remove it.

    As for what is removing it - Well, I've no idea.
     
  3. Did you change your tracking ranges? Those "hide" entities.
     
  4. Nope, my tracking ranges are:
    entity-tracking-range:
    players: 48
    animals: 48
    monsters: 48
    misc: 16
    other: 48
     
    • Funny Funny x 1
  5. Exactly what do you mean by disappearing? Do they get permanently removed or do you just have to walk up very close to them?
     
  6. Permanently get removed.
     
    • Funny Funny x 1
  7. Definitely not activation ranges, sounds more like something that would be caused by clearlagg.
    Are you 100% sure you don't have a plugin clearing entities?
     
  8. Yup, clarlagg wasn't on the server.
     
    • Funny Funny x 1