Premium EpicCraftingsPlus | Fully Configurable CRAFTS! [1.8-1.17] [Paid]

Discussion in 'Resource Discussion' started by Ajneb97, Apr 26, 2017.

  1. Hi friend, it has been a while.

    We updated to 6.6.4 from 6.3.X and started receiving this error. This is when someone tries to open the gui from command, and from a designated "table" if you will;

    https://pastebin.com/7xQyttnY

    Configs are listed;
    https://pastebin.com/fvUZEX7r

    Thanks for continuing to update this amazing plugin. <3
     
  2. The plugin really needs a wiki. It takes a lot of time to search for information in 100+ pages. And the tutorial in overview describes only basics.

    How can I add a potion effect to a weapon?
     
  3. This plugin allows you to create craftings, nothing else. If you want to add a potion effect to an item you need a custom item plugin.
     
  4. It seems in one of your categories, there is no "size" property.
     
    • Like Like x 1
  5. Thank you for that! =D

    EDIT: Found a strange issue when using the "ignore-required-nbt-tags" option on items, now I'm not sure if I am missing a setting or anything from the update, but crafting items with materials that have the exact nbt's takes them away.

    Video;
     
    #2105 SSS.BarX, Oct 25, 2021
    Last edited: Oct 25, 2021
  6. Could you send me the config only of that crafting please?
     
  7. Hi i think it would be better to create a config file for each category instead of putting everything in the main config file.
     
  8. Yes, but now it's not possible, it would require a complete recode of the plugin :/
    Plus I don't think I am going to add new features, the plugin is really not maintanable anymore..
     
  9. Ok, thanks anyway, this is a really great plugin :) The only one still working in 1.12.2
     
    • Like Like x 1
  10. Can you please add a way for players to shift+left-click to craft as much as they can of a recipe??
     
    • Informative Informative x 1
  11. I see you rated this as informative, thank you.
    I just want to say that currently, if i want to allow bulk crafting, I need to add multiple's of the same crafting recipe... and to do that, it fills up the /ecraft menu... so hopefully this can be implemented?
     
  12. i BOUGHT the plugin i paid the money paypal
    Transaction ID
    84Y43826DD706071K

    i did not receive it and its not even there on my ressource list
     
  13. I don't think I wIill update this plugin anymore, read the spoiler on the plugin page please
     
  14. Do you still have this issue? I see you in the buyers list.
     
  15. Well that blows, thank you
     
  16. [12:03:18 LỖI]: Không thể chuyển sự kiện InventoryClickEvent hát EpicCraftingsPlus v6.6.5
    org.bukkit.event.EventException: null
    at org.bukkit.plugin.EventExecutor $ 2.execute (EventExecutor.java:72) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at co.aikar.timings.TimedEventExecutor.execute (TimedEventExecutor.java:78) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at org.bukkit.plugin.RegisteredListener.callEvent (RegisteredListener.java:62) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at org.bukkit.plugin.SimplePluginManager.callEvent (SimplePluginManager.java:513) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.PlayerConnection.a (PlayerConnection.java:2002) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.PacketPlayInWindowClick.a (SourceFile: 33) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.PacketPlayInWindowClick.a (SourceFile: 10) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.PlayerConnectionUtils.lambda $ ensureMainThread $ 0 (PlayerConnectionUtils.java:14) ~ [p patch_1.12.2.jar: git-Paper-1618]
    tại java.util.concurrent.Executor $ RunnableAdapter.call (Executor.java:515) ~ [?:?]
    tại java.util.concurrent.FutureTask.run (FutureTask.java:264) ~ [?:?]
    at net.minecraft.server.v1_12_R1.SystemUtils.a (SourceFile: 46) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.D (MinecraftServer.java:850) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.DedicatedServer.D (DedicatedServer.java:423) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.C (MinecraftServer.java:774) ~ [p patch_1.12.2.jar: git-Paper-1618]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run (MinecraftServer.java:666) ~ [p patch_1.12.2.jar: git-Paper-1618]
    tại java.lang.Thread.run (Thread.java:834) [?:?]
    Gởi bởi: java.lang.NullPointerException
    tại ecp.ajneb97.events.Inventario.abrirInventarioCraft (Inventario.java:1191) ~ [?:?]
    at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventExecutor370.execute (Nguồn không xác định) ~ [?:?]
    at org.bukkit.plugin.EventExecutor $ 2.execute (EventExecutor.java:70) ~ [p patch_1.12.2.jar: git-Paper-1618]
    ... 15 nữa




    Help me pls
     
  17. When does this error happens? Do you have any other error?
     
  18. When is this Plugin releasing for 1.18?
     
  19. As it is said in the description of the plugin, I will not update it anymore. If a lot of people require the update to 1.18 I will consider it.