"epoll channel" & "Failed to generate a seed from Secure Random"?

Discussion in 'Spigot Help' started by Diamond_King099, May 25, 2016.

  1. So I've setup a Bungee network (1.9.2) on an OVH VPS. When I start my Spigot server, it gives me these two messages:

    and
    It didn't happen at first, only after I had modified my configs. I changed them all back to default and edited them one by one. It appears that something in my spigot.yml is causing it. Here's my file:

    Code (Text):
    # This is the main configuration file for Spigot.
    # As you can see, there's tons to configure. Some options may impact gameplay, so use
    # with caution, and make sure you know what each option does before configuring.
    # For a reference for any variable inside this file, check out the Spigot wiki at
    # http://www.spigotmc.org/wiki/spigot-configuration/
    #
    # If you need help with the configuration or have any questions related to Spigot,
    # join us at the IRC or drop by our forums and leave a post.
    #
    # IRC: #spigot @ irc.spi.gt ( http://www.spigotmc.org/pages/irc/ )
    # Forums: http://www.spigotmc.org/

    config-version: 8
    settings:
      save-user-cache-on-stop-only: false
      bungeecord: true
      late-bind: true
      sample-count: 12
      player-shuffle: 0
      filter-creative-items: true
      user-cache-size: 1000
      int-cache-limit: 1024
      moved-wrongly-threshold: 0.0625
      moved-too-quickly-multiplier: 10.0
      timeout-time: 60
      restart-on-crash: true
      restart-script: ./start.sh
      netty-threads: 4
      attribute:
        maxHealth:
          max: 2048.0
        movementSpeed:
          max: 2048.0
        attackDamage:
          max: 2048.0
      debug: false
    commands:
      tab-complete: 2
      log: true
      spam-exclusions:
      - /skill
      silent-commandblock-console: false
      replace-commands:
      - setblock
      - summon
      - testforblock
      - tellraw
    messages:
      whitelist: You are not whitelisted here!
      unknown-command: Unknown command.
      server-full: The server is full!
      outdated-client: Outdated client! Please use {0}
      outdated-server: Outdated server! I'm still on {0}
      restart: Server is restarting
    stats:
      disable-saving: false
      forced-stats: {}
    world-settings:
      default:
        verbose: true
        mob-spawn-range: 4
        nerf-spawner-mobs: false
        growth:
          cactus-modifier: 100
          cane-modifier: 100
          melon-modifier: 100
          mushroom-modifier: 100
          pumpkin-modifier: 100
          sapling-modifier: 100
          wheat-modifier: 100
          netherwart-modifier: 100
        entity-activation-range:
          animals: 32
          monsters: 32
          misc: 16
        entity-tracking-range:
          players: 48
          animals: 48
          monsters: 48
          misc: 32
          other: 64
        ticks-per:
          hopper-transfer: 8
          hopper-check: 8
        hopper-amount: 1
        random-light-updates: false
        save-structure-info: true
        max-entity-collisions: 8
        dragon-death-sound-radius: 0
        seed-village: 10387312
        seed-feature: 14357617
        hunger:
          walk-exhaustion: 0.2
          sprint-exhaustion: 0.8
          combat-exhaustion: 0.3
          regen-exhaustion: 3.0
        max-tnt-per-tick: 100
        max-tick-time:
          tile: 50
          entity: 50
        item-despawn-rate: 6000
        merge-radius:
          item: 2.5
          exp: 3.0
        arrow-despawn-rate: 1200
        enable-zombie-pigmen-portal-spawns: true
        wither-spawn-sound-radius: 0
        view-distance: 10
        hanging-tick-frequency: 100
        zombie-aggressive-towards-villager: true
     

    Any help would be appreciated.
    Thanks!
     
  2. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    I think it's netty related. You managed to get rid of the error, what's your issue?:)
     
  3. Well the error doesn't appear with the default spigot.yml, but when I change the settings the way I want them the error comes back.
     
  4. i9hdkill

    i9hdkill Retired Moderator
    Retired Supporter

    Can you exactly tell us what settings?
     
  5. bungeecord: true
    late-bind: true
    tab-complete: 2
    changed a few of the messages

    Those are the only values I changed in the spigot.yml file.
     
  6. Ran a local server on my PC using my spigot.yml and it just says "Using default channel type".

    I've restarted the one on the VPS several times and sometimes it gives the SecureRandom error and sometimes it doesn't. It always says "Using epoll channel" though.

    I narrowed it down some more and it appears that the "late-bind" option is causing it. It's very strange though, as I have used late-bind on my other servers without an issue. With late-bind off, it still says "Using epoll channel type" but instead of it being the last thing in the log, it shows up near the top.

    So, what is this "epoll channel type" and why does it only show up on my VPS server? I did some Googling and I believe it has something to do with the Linux I/O system. Maybe it's only showing up on the VPS because it's running Ubuntu and my PC is running Windows?

    And any ideas why late-bind appears to be causing that SecureRandom error?

    Thanks!
     
  7. Turning off late-bind seems to have fixed the issue on the Spigot server, but now it's happening with my BugeeCord server.

    Same "Failed to generate a seed from SecureRandom within 3 seconds. Not enough entrophy?" error. I deleted all the files and configs, and even with everything set to default it still happens.

    I don't understand what's causing it, much less how to fix it...

    Any help would be appreciated.
     
  8. I tried asking on the Ask Ubuntu as well, but it very quickly got voted to be closed because of being off topic and not an Ubuntu issue.

    I've tried researching the problem, but haven't been able to find anything...

    I don't know what else to try. Surely someone knows what could be causing it?
     
  9. sothatsit

    Patron

    Im not sure if it is caused by an error, but what the error means is that there are not enough sources running in your computer for it to generate a random seed from (which is the way secure random works, instead of using the time, hence why it is secure). You can read more about it here: http://stackoverflow.com/questions/...aphically-secure-random-number-generator-work

    Although this explains your issue, I don't know how you would go about fixing it.
     
    • Useful Useful x 1
  10. Thanks for the reply.

    So, basically, in order for it to generate a "seed", it needs to get a random value from somewhere on the system that a person can not monitor, correct? So that would mean that my VPS doesn't have enough processes running for it to get random data from?

    I reinstalled Bungee and my Spigot servers, and the error didn't come up for awhile, then it just randomly appeared again. Everything appears to be working though, but I don't like seeing an error there...
     
    • Useful Useful x 1