1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Solved Error enabling worldguard! IDK why.... :(

Discussion in 'Bugs & Feature Requests' started by YaraTag, Apr 26, 2020.

  1. [14:27:42] [Server thread/ERROR]: Error occurred while enabling WorldGuard v7.0.2-SNAPSHOT;bf2593e (Is it up to date?)
    java.lang.NoClassDefFoundError: org/sqlite/NativeDB
    at java.lang.ClassLoader$NativeLibrary.load(Native Method) ~[?:1.8.0_241]
    at java.lang.ClassLoader.loadLibrary0(Unknown Source) ~[?:1.8.0_241]
    at java.lang.ClassLoader.loadLibrary(Unknown Source) ~[?:1.8.0_241]
    at java.lang.Runtime.load0(Unknown Source) ~[?:1.8.0_241]
    at java.lang.System.load(Unknown Source) ~[?:1.8.0_241]
    at org.sqlite.SQLiteJDBCLoader.loadNativeLibrary(SQLiteJDBCLoader.java:274) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.SQLiteJDBCLoader.loadSQLiteNativeLibrary(SQLiteJDBCLoader.java:310) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.SQLiteJDBCLoader.initialize(SQLiteJDBCLoader.java:64) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.core.NativeDB.load(NativeDB.java:63) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.SQLiteConnection.open(SQLiteConnection.java:235) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.SQLiteConnection.<init>(SQLiteConnection.java:61) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.jdbc3.JDBC3Connection.<init>(JDBC3Connection.java:28) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.jdbc4.JDBC4Connection.<init>(JDBC4Connection.java:21) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.JDBC.createConnection(JDBC.java:115) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.sqlite.JDBC.connect(JDBC.java:90) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at java.sql.DriverManager.getConnection(Unknown Source) ~[?:1.8.0_241]
    at java.sql.DriverManager.getConnection(Unknown Source) ~[?:1.8.0_241]
    at com.sk89q.worldguard.util.profile.cache.SQLiteCache.<init>(SQLiteCache.java:64) ~[?:?]
    at com.sk89q.worldguard.WorldGuard.setup(WorldGuard.java:83) ~[?:?]
    at com.sk89q.worldguard.bukkit.WorldGuardPlugin.onEnable(WorldGuardPlugin.java:144) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:352) [spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:417) [spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugin(CraftServer.java:462) [spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at org.bukkit.craftbukkit.v1_15_R1.CraftServer.enablePlugins(CraftServer.java:376) [spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at net.minecraft.server.v1_15_R1.MinecraftServer.a(MinecraftServer.java:457) [spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at net.minecraft.server.v1_15_R1.DedicatedServer.init(DedicatedServer.java:267) [spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:784) [spigot-1.15.2.jar:git-Spigot-800b93f-8160e29]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_241]
    Caused by: java.lang.ClassNotFoundException: org.sqlite.NativeDB
    at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.8.0_241]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_241]
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) ~[?:1.8.0_241]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_241]
    ... 29 more
     
  2. Who is the version of the server and the plugin?
     
  3. My server version is 1.15.2 and the worldguard version is 7.0.2. it says it in the error log
     
    #3 YaraTag, Apr 26, 2020
    Last edited: Apr 26, 2020
  4. I have the same problem. How did you solve the problem?