Solved Error in console // Can't connect

Discussion in 'BungeeCord Help' started by ExplosiveNight, Jun 2, 2017.

Thread Status:
Not open for further replies.
  1. Hello everyone! I am starting a new server called skyoto, and whenever I try to start our bungee this happens:
    Config:
    Code (Text):

    ip_forward: false
    network_compression_threshold: 256
    stats: 6e837b7f-3a5d-49f3-bb87-2d77979461a1
    groups:
      explosivenight:
      - admin
    servers:
      lobby:
        motd: '&1Just another BungeeCord - Forced Host'
        address: localhost:25566
        restricted: false
      green:
        motd: 'hello world'
        address: localhost:25567
        restricted: false
    timeout: 30000
    player_limit: -1
    listeners:
    - query_port: 25565
      motd: '&bSkyoto | In Development'
      priorities:
      - hub1
      bind_local_address: true
      tab_list: GLOBAL_PING
      query_enabled: false
      host: 0.0.0.0:25565
      forced_hosts:
        pvp.md-5.net: pvp
      max_players: 1
      tab_size: 60
      ping_passthrough: false
      force_default_server: false
    prevent_proxy_connections: false
    permissions:
      default:
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
    online_mode: true
    log_commands: false
    disabled_commands:
    - disabledcommandhere
    connection_throttle: 4000

     
    Log:
    Code (Text):

    21:05:05 [INFO] Using OpenSSL based native cipher.
    21:05:05 [INFO] Using native code compressor
    21:05:05 [INFO] Enabled BungeeCord version git:BungeeCord-Bootstrap:1.12-SNAPSHOT:e26b937:1236
    21:05:05 [INFO] Not on Windows, attempting to use enhanced EpollEventLoop
    21:05:05 [INFO] Epoll is working, utilising it!
    21:05:05 [INFO] Discovered module: ModuleSpec(name=cmd_alert, file=modules/cmd_alert.jar, provider=JenkinsModuleSource())
    21:05:05 [INFO] Discovered module: ModuleSpec(name=cmd_find, file=modules/cmd_find.jar, provider=JenkinsModuleSource())
    21:05:05 [INFO] Discovered module: ModuleSpec(name=cmd_list, file=modules/cmd_list.jar, provider=JenkinsModuleSource())
    21:05:05 [INFO] Discovered module: ModuleSpec(name=cmd_send, file=modules/cmd_send.jar, provider=JenkinsModuleSource())
    21:05:05 [INFO] Discovered module: ModuleSpec(name=cmd_server, file=modules/cmd_server.jar, provider=JenkinsModuleSource())
    21:05:05 [INFO] Discovered module: ModuleSpec(name=reconnect_yaml, file=modules/reconnect_yaml.jar, provider=JenkinsModuleSource())
    21:05:05 [INFO] Loaded plugin reconnect_yaml version git:reconnect_yaml:1.12-SNAPSHOT:e26b937:1236 by SpigotMC
    21:05:05 [INFO] Loaded plugin cmd_find version git:cmd_find:1.12-SNAPSHOT:e26b937:1236 by SpigotMC
    21:05:05 [INFO] Loaded plugin cmd_server version git:cmd_server:1.12-SNAPSHOT:e26b937:1236 by SpigotMC
    21:05:05 [INFO] Loaded plugin cmd_alert version git:cmd_alert:1.12-SNAPSHOT:e26b937:1236 by SpigotMC
    21:05:05 [INFO] Loaded plugin cmd_send version git:cmd_send:1.12-SNAPSHOT:e26b937:1236 by SpigotMC
    21:05:05 [INFO] Loaded plugin cmd_list version git:cmd_list:1.12-SNAPSHOT:e26b937:1236 by SpigotMC
    21:05:05 [SEVERE] Exception in thread "main"
    21:05:05 [SEVERE] java.lang.IllegalArgumentException: Server hub1 (priority 0) is not defined
    21:05:05 [SEVERE]     at com.google.common.base.Preconditions.checkArgument(Preconditions.java:145)
    21:05:05 [SEVERE]     at net.md_5.bungee.conf.Configuration.load(Configuration.java:123)
    21:05:05 [SEVERE]     at net.md_5.bungee.BungeeCord.start(BungeeCord.java:265)
    21:05:05 [SEVERE]     at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:55)
    21:05:05 [SEVERE]     at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)
     
    I have no idea what is causing this error. Thank you for any help :)
     
    #1 ExplosiveNight, Jun 2, 2017
    Last edited: Jun 2, 2017
  2. I tried parsing the config and nothing changed...
     
  3. Gaxan

    Supporter

    Change - hub1 to - lobby

    or define hub1 server like you did for lobby and green.
     
    #3 Gaxan, Jun 2, 2017
    Last edited: Jun 2, 2017
  4. @Gaxan that fixed it! Thanks for the help!
     
Thread Status:
Not open for further replies.