Error in the server

Discussion in 'Spigot Help' started by Mikknirman, Jan 13, 2020.

  1. Hello!
    I'm running a Minecraft Spigot Server and I keep getting this error that I can't manage to fix.


    ERROR code:

    [ERROR] Exception stopping the server

    java.lang.IllegalStateException: Removing entity while ticking!

    at net.minecraft.server.v1_15_R1.WorldServer.removeEntity(WorldServer.java:1159) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.WorldServer.removePlayer(WorldServer.java:1178) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.PlayerList.disconnect(PlayerList.java:414) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.PlayerConnection.a(PlayerConnection.java:1370) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.PlayerConnection.disconnect(PlayerConnection.java:268) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.PlayerList.shutdown(PlayerList.java:1012) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.MinecraftServer.stop(MinecraftServer.java:708) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.DedicatedServer.stop(DedicatedServer.java:683) ~[spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at net.minecraft.server.v1_15_R1.MinecraftServer.run(MinecraftServer.java:863) [spigot-1.15.1.jar:git-Spigot-037559e-e8cb2f5]

    at java.lang.Thread.run(Thread.java:813) [?:1.8.0_212]
     
  2. I'll add that when it appears it stopps the server and re-entering after the restart brings your buildings back to 1-2 minutes.
     
  3. A crash or force close will not save the world to how it was exactly when it crashed, so thats expected.

    But please use a pastebin to paste your whole console log from startup, to where it closes. This simply isnt enough information.
     
  4. Line 930. Is the world corrupt?
    Line 1080. More...
    Edited the previous post to not cause confusion
     
    #5 lokka30, Jan 14, 2020
    Last edited: Jan 15, 2020
    • Like Like x 1
  5. Line 930 and 1080: The worlds that it's about isn't used, it should be deleted by multiverse command and the folder. I did /mv remove and removed those. Thank you for pointing out.

    Line 8: I don't know why it says Craftbukkit. I use Spigot 1.15.1 and Spigot plugins.
     
  6. You do know that Spigot is a fork of bukkit, right ? All spigot versions say this on startup...
     
    • Like Like x 1
  7. I know, but didn't know that it says that.
     
  8. It says that because its meant to say that!! Its not a bad thing, or even anything to care for. Idk why Lokka even mentioned it...
     
  9. I understand. I was confused why Lokka mentioned it.
     
  10. I have noticed you have a lot of plugins. Maybe one of them are having some issues?

    The crashes seem to be caused by entities. Maybe run a timings report and see if you have issues with entities.
     
  11. I am sure that it is a problem with plugin, but I can't seem to find it. I think it happens, because I tried to update server from 1.14 to 1.15 with same plugins, but update the source and maybe some things are broken now.

    How do you run the timings report?
     
  12. Oh, its likely all the plugins need to be updated to their latest versions, so make sure you do this.

    Using timings is simple, do /timings in-game, and the rest should be straight forward for you.
     
  13. The thing is that some, 5-6 plugins are old bukkit plugins that so far have worked (such as anticreeper and levelhearts), but some may not or parts of them may cause anything. I just thought that maybe someone knows the solution to the exact error.
     
  14. Woah, relax. I didn’t know that, I’m sorry. I actually had a thought it was something all platforms said but I leant towards it being a CB-only thing. Edited my post to not cause confusion in the future.:D
     
    • Like Like x 2