Error occurred while contacting login servers, are they down?

Discussion in 'BungeeCord Discussion' started by Expo, Jul 19, 2014.

Thread Status:
Not open for further replies.
  1. Hello,

    I have had the above error twice now. Players received that message when they tried to login and it did not allow them to join until I restarted the proxy. Login servers were not actually down at the time as I could join other servers. It seems to just randomly occur(players can join fine most of the time). I have made sure my firewall rules are correct(port 80 and 443 are allowed) so I do not believe it is a network/firewall issue.


    I receive the error below when a user tries to join(when this randomly occurs):
    http://pastebin.com/TmiwUCtL

    I receive a similar error too:
    http://pastebin.com/7qN13HHh

    Could this possibly be a bug? It is quite odd as it just randomly happens. Thanks for any help!
     
  2. It's not a bug. Probably something with your internet connection or mojang servers.
     
  3. My firewall is setup properly(I run on OVH as well so there would be no network connectivity problems) and mojang servers were up at the time.
     
  4. md_5

    Administrator Developer

    Can you please read errors before posting them?

    Expected HTTP response 200 OK, got 503 Service Unavailable: Back-end server is at capacity
    503 Service Unavailable: Back-end server is at capacity
    Back-end server is at capacity


    This is a Mojang issue. not a Bungee issue.
     
    • Agree Agree x 4
  5. I was getting this too. Unable to login to my server with the same error. Tried at least a dozen different times over the past 30 minutes. Tried one last time, got this error, restarted proxy and was instantly able to log in and out repeatedly without issue. That doesn't seem like a mojang issue despite the error text.
     
  6. The servers for Mojang are up though.

    The issue is resolved when you restart your Bungeecord.
     
  7. md_5

    Administrator Developer

    Can you please read what I said:

    Expected HTTP response 200 OK, got 503 Service Unavailable: Back-end server is at capacity
    503 Service Unavailable: Back-end server is at capacity
    Back-end server is at capacity

    Which part of Mojang's API returning an HTTP error 503 "Service Unavailable: Back-end server is at capacity" is BungeeCord's fault? Mojang's servers are telling BungeeCord that they are currently at capacity!
     
    • Agree Agree x 1
  8. I've read what you have said and I understand that. The thing I am stating is a simple restart fixed the problem. The servers were not at capacity the one Bungeecord was connecting to was. I don't know how Bungeecord or Mojang server shit works but by the looks of things whatever Bungeecord was connecting to was saying it was down. After a Bungeecord restart it could connect again.

    So my theory is that Bungeecord was connecting to a certain IP and when that went down on Mojangs bungeecord kept trying to connect to that IP when it changed.

    Its not Bungeecord's fault that the server went down in the first place but it seemed to be connecting to something and erroring even though essentially it was up.
     
  9. md_5

    Administrator Developer

    Mojang runs many different servers. If they are "at capacity" not every single request is going to fail, just the ones which bring it over capacity.
     
  10. Okay but all requests were failing so I assumed it would be down. But after restart everything works fine again. So what it seemed like was Bungeecord was trying to connect to down servers when others were up. Couldn't you check if that server was over capacity and try another instead?
     

  11. You are wrong sir... just had this situation 10 minutes ago... My network keep saying:
    error occurred while contacting login servers. Are they down
    Mineplex heep saying the same... Then after few minutes I noticed mineplex is up but my server is still down for premium users...

    I restarted my bunge 4 minutes ago and its fine now... So as Spurlex said... Bungee keeps some informations about auth server that went down - untill you restart bungee you won't get online as premium.
     
  12. While it was a huge necro.
    I did have to restart my bungee 2 times today for players to be allowed to join.
    And I noticed a lot of other servers were having the same issue, including Mineplex. (Early morning US today)

    I was just assuming it had something to do with the upcoming name change crap.
     
  13. I can vouch for this. I saw that login servers were down earlier for all servers. Later, I could access pretty much all other servers, but I kept getting that same error message constantly for my own server. It was fixed with a restart of bungee.
     
  14. jflory7

    jflory7 Retired Moderator
    Retired Benefactor

    Thread cleaned

    Remember, if you report something and then reply back to it, provoking a fight, you are just as much as guilty as whoever you're reporting.

    Hit the button and move on.
     
  15. I am getting this issue but no matter how many times I restart bungee it doesn't work :(
     
  16. MikeA

    MikeA Retired Moderator
    Retired Benefactor

    Please open a new thread, your issue could be DNS related.
     
    • Like Like x 2
Thread Status:
Not open for further replies.