Error on start

Discussion in 'Spigot Plugin Help' started by haggishunter2001, May 22, 2016.

  1. Hey,

    when I start the Server, my plugin give me this Error:
    Code (Text):
    [16:02:25] [Server thread/ERROR]: Could not load 'plugins/Labor.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: de/Labor/www/Main : Unsupported major.minor version 52.0
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.reload(CraftServer.java:739) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.Bukkit.reload(Bukkit.java:535) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:641) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchServerCommand(CraftServer.java:627) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at net.minecraft.server.v1_8_R3.DedicatedServer.aO(DedicatedServer.java:412) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:375) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:653) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:556) [spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at java.lang.Thread.run(Thread.java:745) [?:1.7.0_101]
    Caused by: java.lang.UnsupportedClassVersionError: de/Labor/www/Main : Unsupported major.minor version 52.0
        at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_101]
        at java.lang.ClassLoader.defineClass(ClassLoader.java:803) ~[?:1.7.0_101]
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) ~[?:1.7.0_101]
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) ~[?:1.7.0_101]
        at java.net.URLClassLoader.access$100(URLClassLoader.java:71) ~[?:1.7.0_101]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:361) ~[?:1.7.0_101]
        at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_101]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_101]
        at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_101]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:425) ~[?:1.7.0_101]
        at java.lang.ClassLoader.loadClass(ClassLoader.java:358) ~[?:1.7.0_101]
        at java.lang.Class.forName0(Native Method) ~[?:1.7.0_101]
        at java.lang.Class.forName(Class.java:278) ~[?:1.7.0_101]
        at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot_server.jar:git-Spigot-fdc1440-53fac9f]
        ... 14 more
    Can somebody help me?

    Best wishes,
    Tobias
     
  2. Is your server on Java 7 or Java 8?
     
  3. Update Java to 1.8. You shouldn't be using 1.7 any more anyway as it's EOL.
     
  4. What does that mean?
     
  5. End Of Life. :p
     
  6. I use Java 8 (PC and Server)
     
  7. What's the output of
    Code (Text):

    java -version
     
    ...on your server? The error means the plugin is compiled in a version of Java later than the one on the server.
     
  8. Most likely, you have Java 8 installed, but you still use Java 7. Send us what @dwilson390 said above, java -version should display which version you're running.
     
    • Like Like x 1